Can't access to my synology after installing pi-hole

First of all: I'm new to pi-hole, so bear with me, please
In my home network I have an ubuntu server with a fixed IP (and it needs to stay fixed to that IP)
I also have a synology NAS, again With fixed IP,
I have a router that was providing IP via DHCP on all the devices in the house, except for those two.
I then installed pi-hole in the ubuntu server, disabled the DHCP on the router, since it does not allow me to set the DNS and enabled the DHCP on the NAS.
In the DHCP configuration I set as primary DNS, to force all the clients to use pi-hole as DNS.
Is this all right until now?

If it is as I think, I can't understand why I'm having issues to connect to my NAS from outside my home network.
Before I could connect to the NAS at, now I can't.
What can I check to restore the ability to connect to the NAS from the internet?

This does not force clients to use this DNS. It is offered, but clients are free to ignore it. For example - manual DNS assignment in a client, hard-coded DNS on the client, etc.

Yes, I was wrong.
But the issue is still there: why I can't connect to my synology?
I also forget to say that I set as primary DNS on my NAS.

From the client on which you are unable to connect to the Synology, what is the output of the following from the command prompt or terminal on that client (and not via ssh to the Pi-hole host):


Sorry for the late answer.
the output is:

fmf@kodi:~$ nslookup

Non-authoritative answer:
Address: (this is a public IP)

Now it works, I was out of options, so I did the old trick: I did a reboot of the pi-hole server and of the nas and the router.