Can't access admin interface, new install on Ubuntu 20 VM

Expected Behaviour:

Ubuntu 20 VM on hosted on Unraid, fresh install
browse to 192.168.1.223/admin
pihole web admin page should load

Actual Behaviour:

Page times out

Debug Token:

https://tricorder.pi-hole.net/RUP6mqYn/

Thanks for any assistance!

Can you try the command below from a Linux machine on the network?

curl --head http://192.168.1.223/admin/login.php

Here ya go!

ericdowning@Studio23 ~ % curl --head http://192.168.1.223/admin/login.php
HTTP/1.1 200 OK
**Expires**: Thu, 19 Nov 1981 08:52:00 GMT
**Cache-Control**: no-store, no-cache, must-revalidate
**Pragma**: no-cache
**Set-Cookie**: PHPSESSID=0i9gk2u6sgdjomtcc705h5oe4d; path=/; HttpOnly; SameSite=Strict
**Content-type**: text/html; charset=UTF-8
**X-Pi-hole**: The Pi-hole Web interface is working!
**X-Frame-Options**: DENY
**X-XSS-Protection**: 0
**X-Content-Type-Options**: nosniff
**Content-Security-Policy**: default-src 'self' 'unsafe-inline';
**X-Permitted-Cross-Domain-Policies**: none
**Referrer-Policy**: same-origin
**Date**: Tue, 21 Nov 2023 01:29:50 GMT
**Server**: lighttpd/1.4.55

Thankyou, well that is showing that the Pi-hole web server is up and running and responding. Can you try that full URL in the browser on the original machine please?

http://192.168.1.223/admin/login.php

Is the original machine definitely on the same network? Is it running any VPN stuff? Are any private browsing services disabled (which might be funneling traffic through a proxy), and so on?

Are you able to reach the full URL from a browser on the machine you did the curl from (assuming it has a desktop environment), or perhaps a smartphone on the same network. Basically trying to narrow it down to a problem with a settings in that original browser or perhaps whole machine's networking.

Thank you for your help. I've tried http://192.168.1.223/admin/login.php from all my devices, wired and wireless, mobile and desktop, different browsers (safari/brave with and without shields) and they all spin for about 5 minutes then I just get the standard timeout message. I've opened all ports as per documentation on the device itself and I'm able to telnet to port 80.

I've used piholes for years and I currently have two others that are working flawlessly, same config. The only difference between those and this one is that the working piholes are hosted on PVE while the problematic pihole is running off a VM hosted on Unraid. I've never had this issue before and thus I remain flummoxed.

Interesting note is that if I misspell the URL I'll get an immediate 404 such as:

http://192.168.1.223/admin/lgin.php

Do you have any firewall blocking port 80 in your VM?

Although I've never had to unblock any ports I went ahead as part of my troubleshooting and unblocked ports as per documentation:

ericdowning@Studio23 ~ % nc -zv 192.168.1.223 80
Connection to 192.168.1.223 port 80 [tcp/http] succeeded!

If you try to curl the page (without any flags), do you receive the file?

curl http://192.168.1.223/admin/login.php

Expected answer:
(I didn't post the full output)

<!DOCTYPE html>
<!--
*  Pi-hole: A black hole for Internet advertisements
*  (c) 2017 Pi-hole, LLC (https://pi-hole.net)
*  Network-wide ad blocking via your own hardware.
*
*  This file is copyright under the latest version of the EUPL.
*  Please see LICENSE file for your rights under this license.
-->
<html lang="en">
<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <!-- Usually browsers proactively perform domain name resolution on links that the user may choose to follow. We disable DNS prefetching here -->
    <meta http-equiv="x-dns-prefetch-control" content="off">
(... removed ...)
<script src="scripts/pi-hole/js/footer.js?v=1697402395"></script>
</body>
</html>

Interesting. I do not. On the working piholes I am able to see the expected results but not on the .223 device:

curl http://192.168.1.223/admin/login.php

curl: (56) Recv failure: Connection reset by peer

Try this command:

curl -v http://192.168.1.223/admin/login.php

Thanks a lot for looking at this with me.

curl -v http://192.168.1.223/admin/login.php
*   Trying 192.168.1.223:80...
* Connected to 192.168.1.223 (192.168.1.223) port 80 (#0)
> GET /admin/login.php HTTP/1.1
> Host: 192.168.1.223
> User-Agent: curl/7.87.0
> Accept: */*
> 
* Recv failure: Connection reset by peer
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer

I think this is a network issue (a firewall or a routing issue).

Are you sure there is no firewalls on the host (not inside the VM) or the router?

Are they also running on Unraid? If not – which, since they are working, could imply an Unraid-specific issue – is there a default security or network setting that needs tweaking?

The other two piholes are running on a VM hosted on (2) separate Proxmox instances. I pored through my firewall rules earlier but I'm going to check again and see if there is some LAN rule that could be impacting this traffic.

Aside from the pihole install it's a stock (updated) install of Ubuntu Server 20.

> 
> sudo ufw status
> 
> Status: inactive

Could it be SELinux related?

I turned off potential rules for this ip address at my firewall, essentially DMZ'ing it and still no dice. I compared the firewall entry for all the piholes and they are identical in terms of settings. Unraid doesn't have a built-in firewall and there are no firewall settings for the actual VM itself.

Just for fun I spun up a new Ubuntu 22 VM on a different IP (.224), updated it, installed pihole, and same results. It's gotta be something on my network. Just baffling me because SSH works, and all tests to port 80 work.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.