Cannot load long term data from Web GUI

#1

Same issues here, no matter which browser (Safari, Firefox, Chrome): Browsing the dashboard works without issues but doing any queries from the “Long term data” (“Graphics”, “Query Log” or “Top Lists”) never finish (just the spinning loading icon) even when just picking yesterday to show/query.

I’m running on a Raspberry 3B+ and attached SSD (USB/SATA converter cable) with Raspbian Stretch latest version and all updates applied.
Recent Pi-Hole with FTL 4.2.3 installed on April 4th.

What can be checked/done to get it working?

0 Likes

Clients over Time, Query Types and Forward Destinations graphs constantly loading
#3

Run pihole -d for a debug token.

0 Likes

#4

https://tricorder.pi-hole.net/lcujvjeins!

0 Likes

#5

You have Apache running on port 80 which is interfering with lighttpd (the default web server for Pi-Hole).

*** [ DIAGNOSING ]: Dashboard and block page
[✗] Block page X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Date: Tue, 09 Apr 2019 10:07:21 GMT
Server: Apache/2.4.25 (Raspbian)
Last-Modified: Mon, 08 Apr 2019 12:28:24 GMT
ETag: "ff-58603f90ae432"
Accept-Ranges: bytes
Content-Length: 255
Vary: Accept-Encoding
Content-Type: text/html

[✗] Web interface X-Header: X-Header does not match or could not be retrieved.
HTTP/1.1 200 OK
Date: Tue, 09 Apr 2019 10:07:21 GMT
Server: Apache/2.4.25 (Raspbian)
Set-Cookie: PHPSESSID=4j2a81k0pqcgoh268p7dooqug5; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Vary: Accept-Encoding
Content-Type: text/html; charset=UTF-8
0 Likes

#6

Hi,

Yes, I know but Apache was already running when I installed Pi-Hole so shouldn‘t the installer have detected it?

Do I have to install lighthttpd for pi-hole?

Or how can I tell it to use Apache?

Best,

Andreas

0 Likes

#7

Right now we only support lighttpd. You can make a custom config for Apache, but we can not support it.

0 Likes

#9

Hi, Yes, it’s running on Apache (not conflicting with lighttpd as lighttpd is not installed) and almost everything is working (admin page, blocking, statistics, 404-document etc.) but all long-term-data functions fail.

The Apache-logfile says:
[Thu Apr 11 16:36:18.878103 2019] [:error] [pid 2473] [client 192.168.10.50:50359] PHP Fatal error: Uncaught Error: Class ‘SQLite3’ not found in /var/www/html/admin/api_db.php:71\nStack trace:\n#0 /var/www/html/admin/api_db.php(86): SQLite3_connect(true)\n#1 {main}\n thrown in /var/www/html/admin/api_db.php on line 71, referer: http://192.168.1.3/admin/db_graph.php

so the error is a missing SQLite3-PHP-Class?

0 Likes

#10

You can still use lighttpd alongside Apache, but they can’t both be on port 80. You can change the port for lighttpd in /etc/lighttpd/lighttpd.conf, but this custom setting will be overwritten with each update or repair; you would need to re-enter the change after each update or repair.

0 Likes

#11

Got it working. The PHP-SQLite was not installed…
After a “sudo apt-get install php7.0-sqlite3” and reload of Apache everything works as expected.
No need for ligttpd.
Only change for apache2 was a line
ErrorDocument 404 /pihole/index.php
in the 000-default-conf (for VirtualHost *:80)

0 Likes