Cannot connect to Pi-hole DNS

Briefly, I cannot connect to Pi-hole when I use the configured IP address of the Raspi machine. But I can ping it and use the web interface.

I first discovered this on a Windows client, but the problem seems to be more fundamental, as shown by this telnet session on the Raspi. I can connect to Pi-hole using the loopback address, but not the address on the local network:
20201121T113735

There is also a problem with the dashboard, as illustrated below - the data never appears. I haven't really started trying to solve this myself yet, but I mention it here in case it is relevant to the main issue. It also demonstrates that the IP address on the local network is in itself OK, and Pi-hole is installed there.

Any help much appreciated!

I am not sure this is relevant either, but I have NOT yet disabled SHDC on my Virgin Hub as discussed in an earlier thread:


I wanted to test Pi-hole on one or two Windows machines before moving everything over, so I have configured only those clients to use Pi-hole.

Please generate a debug log, upload it when prompted and post the token here.

Hope this works and is what you want - I am still unfamiliar with Pi-hole. I just opened the admin page on my Raspi and generated it.
https://tricorder.pi-hole.net/wtx2n2v46c

*** [ DIAGNOSING ]: Ports in use
[53] is in use by unbound (https://docs.pi-hole.net/main/prerequisites/#ports)
[53] is in use by unbound (https://docs.pi-hole.net/main/prerequisites/#ports)

You have unbound running on port 53, and this is preventing pihole-FTL from binding on that port.

Stop and disable unbound, or move it to another port other than 53.

Wonderful. Thank you for getting me past that step. It's all looking a lot better now!

The problem was that when I first started I found some random document about using unbound. I thought it was a component of Pi-hole and stared to get it running. Then I discovered the one-line Pi-hole installation. I thought I un-did the stuff I did with unbound, but obviously not entirely.