Cannot access web interface - lighttpd not running

Please follow the below template, it will help us to help you!

Expected Behaviour:

PiHole inital install

Actual Behaviour:

All other systems working fine
Cannot access web interface

Debug Token:

Is there already a Apache webserver running on that system?

Not that I’m aware of. I set up a new raspbian lite image. Do you have a command I could use to check?

Running sudo service httpd status gives “unit httpd.service could not be found”

i have similar problem with new installation. My lighttpd running but without inetrface…

● lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2019-09-10 12:18:12 EEST; 9min ago
Process: 256 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf (code=exited, status=0/SUCCESS)
Main PID: 402 (lighttpd)
Memory: 6.3M
CGroup: /system.slice/lighttpd.service
└─402 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf

Sep 10 12:18:07 raspberrypi systemd[1]: Starting Lighttpd Daemon…
Sep 10 12:18:12 raspberrypi systemd[1]: Started Lighttpd Daemon.

Your debug token is:

Don’t know what operating system you both use, but can you please read or check

for me no luck…

No help. Made no difference to my error logs either. The lighttpd daemon is still offline.

I had the same boring problem.
Pi-hole was running good (for some months) and after a update no more web-interface was aviable.
I followed the insctructions on Lighttpd does not start but this didn’t solved the problem.
But the Idea was good: Installing a program that contains lighttpd.

So I found a workaround:
sudo apt-get install gamin (this re-installs lighttpd)
sudo apt-get purge gamin (this uninstalls lighttpd)
curl -sSL | bash (this re-installs lighttpd for the pi-hole).

For me it worked, I hope it will help you too.

1 Like

Brilliant, this worked! Thank you!

Damn this worked! Thank you! !!

sudo service lighttpd status is the correct command

After a update the same problems are here.
For me it looks like when “apt update” updates lighttpd, the pi-hole settigs are overwritten and the web-interface is no more aviable. Perhaps on another port?

I have updated and simplified my workaround above:
sudo apt purge lighttpd
sudo pihole -r

Best regards

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.