Cannot access web interface - Centos7 install

I've tried installing pihole multiple time on a minimal centos 7 install. pihole installs fine -appears to work fine via commandline. however i cannot access it over the web interface from another system on the same subnet.

This is on a centos 7 VM. i can ssh into the vm from other systems fine - stop / start pihole run debugs, etc a curl -I http://ipaddress/admin returns a 200 on the host running pihole, but get no connection on any other host. im not useing any names yet so DNS shouldnt matter, but the host with pihole install is just using google dns and resolved things fine. ive tried from a laptop on the same subnet and on a different one same issue. only system that can get a response form the web server is the local host.

ive deployed multiple vms to see if i screwed something up but seem to alwasy be the same issue

lighttpd looks to be running fine, tried disabling selinux ans well as putting it in permissive mode.

everything seems ok but cannot connect to the webserver. what im i missing. im a linux noob.

ear4wmhl7w is my log code

Bill

figured it out. firewalld... unblocked all the ports i needed. duh