Cannot access web admin after homebridge update

Running pihole on a homebridge raspbian image. Earlier in the day updated homebridge to v1.1.7. Not sure if this affected anything, but nothing else seems to have changed since last web access.

Expected Behaviour:

Raspberry Pi 3B+ with homebridge raspbian image

Earlier, both pi.hole/admin and [IP]/admin used to open pihole web UI, with summary of sites blocked etc.

Actual Behaviour:

both pi.hole/admin and [IP]/admin lead to homebridge login page instead.

Debug Token: https://tricorder.pi-hole.net/3yvjox47jt

Have run pihole -up
pihole -r to reconfig, and also to repair
restarted everything (client, R-Pi).

Pi-hole version is v5.2.2 (Latest: v5.2.2)
AdminLTE version is v5.2.2 (Latest: v5.2.2)
FTL version is v5.3.4 (Latest: v5.3.4)

[✓] DNS service is listening
[✓] UDP (IPv4)
[✓] TCP (IPv4)
[✓] UDP (IPv6)
[✓] TCP (IPv6)

[✓] Pi-hole blocking is enabled

PING pi.hole (192.168.21.211): 56 data bytes
64 bytes from 192.168.21.211: icmp_seq=0 ttl=64 time=24.824 ms

pi@homebridge:~ $ lighttpd-enable-mod fastcgi
already enabled
Run "service lighttpd force-reload" to enable changes

It looks like nginx took over.

[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 nginx (IPv4)
*:443 nginx (IPv6)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 nginx (IPv4)
*:443 nginx (IPv6)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 nginx (IPv4)
*:443 nginx (IPv6)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 nginx (IPv4)
*:443 nginx (IPv6)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
[80] is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)
*:443 nginx (IPv4)

Oh, what is the solution now?
I was just trying to follow troubleshooting steps from other threads with similar problem.

Remove nginx, or move either nginx or lighttpd to a port other than 80.

Great, just did that! and restarted; and voila everything works as it should! Thank you!

sudo apt-get remove nginx nginx-common
sudo reboot

1 Like