Can Pi-hole install on ChromeOS?

or would it have to be on a VM like docker?

Chrome OS is not on the list of Pi-hole's supported OS.

It would have to be in a supported environment, either a VM or via Docker.

what I have been reading, is to change bios and install a supported version of linux so that pi hole will run natively

I am pretty sure that you can install pi-hole on ChromeOS without running a different OS. Enable Linux, and run
curl -sSL | bash
in the Linux terminal.

Hi, tried to install pi-hole on my Acer R13 chromebook, failed with the following error message:
[x]Downloading and installing FTL
error: URL not found
[x] FTL engine not installed

Wonder if I should use different install cmd? I used the one you suggested above.

Thanks (you're lacking the r in aarch above) works just fine for me.

1 Like

I tried one more time to install pi-hole, it worked! Not sure why the first time it failed.

pihole worked fine, from my Mac and iPhone I can tell a lot of ads were blocked, very happy.
But I can't access the pihole admin from my Mac, at http://pi.hole/admin
I have also tried at the IP address like:

I got safari error message: Safari can't find the server

Any suggestion on how to fix the problem?


pihole installs on chromebooks with Linux Beta.
The admin panel is at this address:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.