Can only see the same 6 clients

When I look at the Toplist Clients and at the Query Log, I can only see the same 6 clients. On my network I have about 20 clients, but I can only see the same 6. Is there something I can do to see all then clients on my network ?

I have enabled Conditional Forwarding

This is an indicator that not all of the network clients are using Pi-Hole, or that some of the clients are showing on the router IP.

I though about trying to use Pihole as DHCP and see if it will solve this problem. But I don’t get why some clients are using Pihole and some are not.

Did you disable the DHCP on your router?

How long has it been since you switched between the two DHCP servers ?

I believe some clients still use the old lease from the prior DHCP server

1 Like

Client-wise, the hostnames sometimes do not show up on the dashboard or the client will not show up at all. One way to get the clients to show up in Pi-hole regardless is to force Pi-hole as the DNS server. To get the hostnames, I had to point my Pi-hole to the router for DNS and enable conditional forwarding to external servers (the router). There are some ways to integrate Pi-hole into your network:

  • Set Pi-hole as the DNS server in the router, depending on the model, it may push the DNS server out via DHCP, or it will use Pi-hole by itself, in that all requests to Pi-hole come from the clients, then to the router, and then to Pi-hole, so it will look like they are originating from the router.
  • Use Pi-hole as a DHCP server. I have done this before, but you are taking a risk if Pi-hole ever goes out, as clients will not be able to associate with the network and they will get a 169.254.0.0 address, etc.
  • Use a DNAT rule to force all clients to use Pi-hole in the router, they should show up in the dashboard
  • Note that when using Pi-hole as the DNS server, disable the DHCP server on your router after Pi-hole is successful with it’s DHCP setup. You may have to reboot many devices or force them to renew their DHCP lease.
  • It is most likely your clients are still using old DNS servers pushed out via DHCP, and you will need to force-renew their lease(s).

I use the DHCP in my router, not in Pi-hole. I use Pi-hole as DNS and my routers LAN-DNS settings is pointing at my Pi-hole.

then you are most likely seeing a lot of Router IP entries.

You would need to broadcast the IP of Pi-hole as your DNS to the clients in order for them to register as entries in the log.

You could also enable the conditional forwarding …

I have Pi-hole set as DNS

I do not use Pi-hole as DHCP, but I’m thinking about trying it

DNAT - I have to check this out. I don’t know nothing about that.

But it looks like that all devices on my guest-network, do not show up in Pi-hole, but all devices on my non-guest-network shows up. I think the solution is somewhere around guest-network/non-guest-network

Conditional forward is already enabled.

I found the problem, but not a solution

I have created a guest-network that most of my devices connect to and all these devices does not show up in Pi-hole. Only devices on my none-guest-network shows up. Anything I can do about that ?

Enable within your router the option for guests devices to see/be seen by the main network.

I don’t think I have an option for that in my router. But I’ll try to see

You can put these devices back on the main network and they will all see the Pi-Hole.

I could do that, but I created a guest-network for safety reasons and would like to keep it that way. But it seems to be the only way to fix this. It seems to me that Pi-hole can’t see devices on the guest-network.

It would need to exist on the guest network segment in order to see them.

It sounds like you are using network isolation on the WAP?

You can just send port 53 to the main network. Router willing of course. No security risk there.

@MikeWatson

What vendor?

I have worked with Sagecom (Charter Spectrum), Netgear, Ubiquiti Networks, and DD-WRT.
I do not force Pi-hole on the guest network due to the fact that I respect guest privacy. If a client is supposed to be on our main network, I block them from using guest if that becomes an issue.

I have and ASUS RT-AC68U router with the latest Merlin installed. I have the option on my guest-network to allow “access to intranet”. But then the safty is gone, if my guests can see my main network.

BTW - how can I reply to a post, so that the post I’m answering is inside my post? I can’t find that option

1 Like

Merlin firmware have iptables?