Buster vs Stretch

Hi Pi-Hole community,
Just a quick note for anyone running Buster (raspberry pi too)and Pi-Hole v4.3.1. From my experience, you may want to wait a little while for Buster with Pi-Hole to become completely stable and efficient and stick with Stretch instead. Many users may have never seen these issues. Buster is soon to be supported, (or officially supported very recently). I spent 2 weeks fixing problem after problem, and here are some issues I came across using Buster.

Web admin crashes often
Memory fills up uncontrollably until logs are flushed or Pi reboots
After reinstall:
"Lighttpd config error (fast cgi module)
FTL download error
Query log error
----And resource comparisons (idle) at default number of domains:
Stretch
2% memory usage
.02% cpu usage
Buster
28% memory usage
11% cpu usage
A quick thanks to the devs for their hard work!
So anyone with Stretch reading this in my opinion consider waiting until Buster becomes supported for a while.

If a dev reads this and says Im wrong please listen to him/her and not me:)

I have Pi-Hole on three Pi’s with Buster and have seen none of these issues. Two 3B+ and a Zero W. There are some existing Pi-Hole issues with Buster but they don’t affect most users.

I run 4x Zero W whit Buster, they run whit 0 problems.

I must be a rare exception, or something else was wrong with my software… That is good for Pi-Hole!

I just want to share my experience of upgrading pihole from stretch to buster on a pi 3b.
On my pi, only runs pihole and unbound. I followed the instruction to upgrade from stretch to buster. And during the package upgrade, it asked me to keep current configuration file or use new release file for some packages, like lighttpd, dnsmasq and etc. I assumed I can repair pihole after upgrade, so I chose to use the latest release config file for all packages.

After OS upgrade done, I run pihole -r to repair but failed every time. Seems like no DNS resolving. I had to manually configure the DNS setting. The pihole repair process looks better, at least it download packages and passed FTL installation. Then failed at restart lighttpd. I have no idea how to get that fixed quickly.

So what I did at last yesterday was to flash a new buster lite image and build pihole and unbound from day 0. Hopefully I have a backup pihole server that serving DNS during all those work.

And I also noticed the teleport function does not work as expected. Only imported partial configuration. But failed at complaining one domain is not a valid domain.