[Bug report] Client list is empty after adding new block lists

Hello,

running Pi-holeon an old Raspberry Pi 1, I did a fresh update from 4.x to beta5 some days ago and added clients and groups to test out the new feature - worked like a charm. I then added new block lists via the web interface (always save, no update, except for the last entry).

Now I wanted to add some more clients and face(d) the issue that

  1. the client list is empty, and
  2. I can add the clients
  • 0
  • success
  • message (Error while querying FTL’s database: not an error)
  • Custom, specified below…

Only the last option let’s me enter a free text in the custom IP address field.

I tried to fix this with pihole -up and pihole checkout web release/v5.0, restarted FTL, even the complete Pi1, but to no avail. Finally, pihole checkout core release/v5.0 (or perhaps the automatic pihole -g at the end) fixed the issue.

Cheers,
Timo

Please send us the token generated by

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

What you see came from an only partial checkout of the beta (core was missing). This may have happened because some dependency or whatever failed to install on your first try. It should nothing to worry about, implementing a fallback will be useless as all “normal” users will receive the v5.0 update in one go instead of having to do it in multiple different commands (like the beta testers).

Just to clear up: I upgraded to pihole5 according to https://pi-hole.net/2020/01/19/announcing-a-beta-test-of-pi-hole-5-0/, so first echo, then core, finally web.

Only the re-checkout of core solved the issue for me.

Sorry, debug link: https://tricorder.pi-hole.net/h3jhgolmvq