Blocking only a few ads on sites

Expected Behaviour:

[Block all ads like show in youtube videos etc.]

Actual Behaviour:

[Not blocking all ads. Only a few.]

I’m not sure but in Settings -> DNS tab -> added Upstream DNS Server (192.168.1.30). But when i saved changes, Message “(nothing important) Using 3 DNS servers”. So is it possible to using google’s DNS 8.8.8.8 and Pi Hole at the same time? I’m not expert but i think there may be only 1 DNS server not 3.

This is not the expected behavior in YouTube videos, as the ads are streamed from the same domain as the videos. See this long-running thread on the topic:

As requested in the help template, please generate a Pi-Hole debug log, upload when prompted and post the token here.

Pi-hole is not a full blown DNS resolver, but rather a filtering DNS Proxy (or DNS forwarder, if you prefer).

As such, it is filtering DNS requests for unwanted hostnames, forwarding only those requests for hostnames that don’t match any blocklist entry.

Hence, Pi-hole’s DNS settings pane configures the upstream DNS servers that Pi-hole forwards its allowed requests to.

Pi-hole itself should not be included on this page.
If, as I suspect, Pi-hole resides at 192.168.1.30 in your network, better remove that entry.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.