Blacklisted domains still show IPv4 as “Pi-holed” but not IPv6 in the query log (yet I have IPv6)


#1

Expected Behaviour:

I should see names with Type IPv6 show up as “Pi-holed”, when the domain names of type IPv4 show “Pi-holed” in the logs.

Actual Behaviour:

All IPv6 entries show OK (forwarded) like this pair:

2018-06-13 18:35:38 IPv4 static.ads-twitter.com 2600:1700:5650:bd60::41 Pi-holed - Whitelist
2018-06-13 18:35:38 IPv6 static.ads-twitter.com 2600:1700:5650:bd60::41 OK (forwarded) - Blacklist

Note that my host is running Fedora 28, and I have configured it with an IPv6 address. I made sure to include AAAA_QUERY_ANALYSIS=yes in /etc/pihole/pihole-FTL.conf, and I inserted by IPv6 address in /etc/pihole/setupVars.conf. (I hope that address won’t change because of DHCP; I actually got it from my ISP when I turned DHCP on on my Fedora box).

I read the FAQ that discusses essentially what my topic covers, but in the FAQ the major difference is that people don’t have IPv6 enabled and I do.

I went to http://www.courant.com/breaking-news/ and I see plenty of ads, as well.

Thanks.

Debug Token:

r09btz4sdx


#2

I just added “Enable IPv6 support (SLAAC + RA)” on the Advanced DHCP settings page, and also I think I was confused about which is my IPv6 address because there are two addresses that look similar but are designated as “inet6” on my hosts:

2600:1700:5650:ABCD::49/128
2600:1700:5650:ABCD:xxxx:yyyy:zzzz:aaaa/64

I had set up my pi-hole with the second IP address, but now I changed it to the first so let’s see what happens.


#3

…No change.


#4

Ah- fixed! Looks like my blacklists only got populated with IPv4, because that’s all I had when I set everything up. Now I re-downloaded the blacklists, got the IPv6 addresses, and it worked.

However, it appears that the log still showed the IPv6 as forwarded even though eg the courant.com website was cleaned up very well. So I rebooted my system and now, logs and all, look good.

This is working. Thanks for listening. :slight_smile:

And thanks for Pi-hole!!! I’m going to test drive this and, after a week or so, come back and DONATE!!!


#5

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.