Audit Log Issues and slow load times on streaming services


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

click on a domain and get further information?

Actual Behaviour:

when I click on a domain (allowed or blocked) it will lock the browser

Debug Token:

h1eh2jefsy

Hello all, been searching around for this and found a few hits but nothing that would help. I’ve been trying v4.0 again and it does seem that encrypted sites aren’t an issue but I was looking into why my streaming services are slow to load things like descriptions and menus when I tried to click on entries in the audit log. I will occasionally get the prompt about it taking a long time but mostly it just locks up the tab (IE or Chrome) to the point that I can’t close the tab I have to kill the browser. I also noticed that I have no data in Long Term Data.

The other issue I’m seeing is on my streaming devices (Roku, AppleTV, Amazon, Nvidia Shield). When I’m in any (well the handful I tried) streaming service it’s generally just slow to load, when it does you have to wait extra for descriptions and other items like ratings, previews, etc… to load. It can take 15-30s to load a particular step.

Anyway thank you for your help ahead of time.


#2

Can you post a few screen captures showing what you are seeing on the long term data?

At the main menu for long term data > query log, it is normal to show zeroes until you choose a date and time range.

First screen at long term data > query log:

Select a date range:

Click on the date range:


#4

From your debug log, a few things noted:

Your IP addresses are mismatched, the Pi-Hole is listening on a different IP than the Pi is assigned. IP address 10.0.0.5 for the Pi-Hole, 10.0.2.127 assigned to the ens192 interface.

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the ens192 interface:
   10.0.2.127/22 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

[i] Default IPv4 gateway: 10.0.0.1
   * Pinging 10.0.0.1...
[✓] Gateway responded.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] qgcliwoxgdptz.com is 0.0.0.0 via localhost (127.0.0.1)
[✗] Failed to resolve qgcliwoxgdptz.com via Pi-hole (10.0.0.5)
[✓] doubleclick.com is 216.58.212.206 via a remote, public DNS server (8.8.8.8)

Are you serving Pi-Hole from a remote platform (remote VM, etc.) or over a VPN?


#5

Sorry for the delayed response. I should have been specific, in the long term data it’s the Query Log that has the issue where I get nothing. I just get an error.

I changed the IP on Pi-hole and I could never get the old IP address to go away

. I tried a number of things to get this changed (followed a few posts here) but I could never get that second IP to go away. This is running on an ESXi VM on my local network.

I actually want to use 10.0.0.5 for pi-hole Any guidance would be greatly appreciated.


#6

It is possible to get errors when trying to load long term data (see the warning in yellow).

Does that error pop up immediately, or after a while?


#7

Pops up pretty quickly a few seconds typically.


#8

Do you have php-sqlite3 installed? Without that installed, the web interface can’t interact with the database.


#9

I just followed the instructions to install pi-hole, how can I check to confirm?


#10

php-sqlite3 is a package, so run sudo apt-get install php-sqlite3 to install it if it’s not already installed.


#11

php-sqlite3 is already the newest version (1:7.0+49)

Ok so it looks like it’s installed. Just to make sure I wasn’t crazy, I edited the IP to 10.0.0.5. in `/etc/pihole/setupVars.conf’ and then ran pihole -r and selected repair. did an ip addr and it still hows up as 10.0.2.127

EDIT: I’m just going to nuke this VM and do a fresh install tonight.


#12

Did the fresh install work?


#13

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.