Asus AC68


#143

pj@pj-selgbuild:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether bc:5f:f4:d7:d0:8f brd ff:ff:ff:ff:ff:ff
inet 10.1.1.155/24 brd 10.1.1.255 scope global dynamic noprefixroute enp0s25
valid_lft 86290sec preferred_lft 86290sec
inet6 fe80::fb72:db52:e00b:da0/64 scope link noprefixroute
valid_lft forever preferred_lft forever
pj@pj-selgbuild:~$


#144

pj@pj-selgbuild:~$ cat /etc/resolv.conf

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

DO NOT EDIT THIS FILE BY HAND – YOUR CHANGES WILL BE OVERWRITTEN

127.0.0.53 is the systemd-resolved stub resolver.

run “systemd-resolve --status” to see details about the actual nameservers.

nameserver 10.1.1.240
nameserver 10.1.1.1
pj@pj-selgbuild:~$


#145

pj@pj-selgbuild:~$ nslookup pi.hole

Server: 10.1.1.1
Address: 10.1.1.1#53

** server can’t find pi.hole: NXDOMAIN

pj@pj-selgbuild:~$


#146

Hmmm! I seem to have a problem for every solution!!! :((


#147

Looks like the client is still configured with IP details coming from the router.
Whats output for below one on Pi ?

sudo nmap -sU -p67 --script dhcp-discover 10.1.1.1

EDIT: Ohw and you did reboot this pj-selgbuild client after the switch right ?


#148

But that is probably because I had to turn DHCP back on the router to get access to this pc again?!?

pi@PiHole:~ $ sudo nmap -sU -p67 --script dhcp-discover 10.1.1.1

Starting Nmap 7.40 ( https://nmap.org ) at 2019-03-15 11:54 NZDT
Nmap scan report for router.asus.com (10.1.1.1)
Host is up (0.0037s latency).
PORT STATE SERVICE
67/udp open dhcps
| dhcp-discover:
| DHCP Message Type: DHCPACK
| Server Identifier: 10.1.1.1
| Subnet Mask: 255.255.255.0
| Broadcast Address: 10.1.1.255
| WPAD:
|
| Domain Name Server: 10.1.1.240, 10.1.1.1
|_ Router: 10.1.1.1
MAC Address: cccccccccccccccccc(Asustek Computer)

Nmap done: 1 IP address (1 host up) scanned in 2.03 seconds
pi@PiHole:~ $


#149

Can you post a screenshot of below dhcp settings ?

http://10.1.1.3/admin/settings.php?tab=piholedhcp


#150

As you will see DHCP has not been enabled on the Pi as I could not access the Pi after turning off DHCP on the router as the main PC (wired and with VNC and ssh access to the Pi) was no longer connecting. So, I guess I will have to get out the screen and keyboard to start DHCP on the Pi after shutting it down on the router…or else start it on the Pi before shutting it down on the router??


#151

The order isnt important.
You can first switch on Pi-hole’s DHCP service before you disable the one on the router.
As long as when finished, only one DHCP service is active on your network when you reboot or try renew DHCP leases on the clients.


#152

OK, but what will happen with this wired PC? Is it likely to still function after the switch of DHCP to the Pi?


#153

Maybe not.
But you can switch back DHCP if still have access to router and Pi-hole web GUI from another device ?


#154

OK, thanks…will have to try it later…something has come up, sorry! Thank you so much for your patience and advice!


#155

Was about to say nn as getting late here too.
Good luck.


#156

Thank you so much deHakkelaar, we have all systems go here! You have done a fantastic job, you have been patient, knowledgeable and perceptive…I could not have done this without you guiding me through my many screw ups! You are a champ! :clap::clap::ok_hand::+1:


#157

I have made a contribution under my real name and not my handle!


#158

You were quick to catch up with stuff that most people dont know about how it works!
And a big thanks to the devs and contributors involved!