Another two routers setup troubles


#1

Hi,

I previously as a working pi-hole system, with an all-in-one TP-LInk 8960 modem/router/wifi (192.168.1.1) and NAS (192.168.1.10) wth dockerized pi-hole (192.168.1.20)

But my DSL is so slow that I decide to replace it with 4G.
Now I struggled to have pi-hole works again.
My setup:

  • 4G alcatel hh40 router (192.168.0.1, DHCP: off, WIFI: off)
  • Zyxel router (WAN: 192.168.0.2, WAN gateway: 192.168.0.1, WAN DNS: 8.8.8.8, LAN: 192.168.1.1, DHCP: on, WIFI: on)
  • NAS (192.168.1.10) with dockerized pi-hole (192.168.1.20)

With this setup, I can navigate to the web, but pi-hole is not working.
As soon as I configure Zyxel WAN DNS to 192.168.1.20, nothing works anymore.
I guess pi-hole should be in the WAN domain (192.168.0.*)

Do you have any idea how to set-up?
Maybe it’s impossible, and the solution is to install pi-hole on a dedicated rpi/odroid and plug it directly on the 4G router. (192.168.0.XX)

Thanks


#2

Sounds like the Zyxel router has a problem with routing the requests to it’s 192.168.1.* IPs when the DNS is set to those IPs.

Does it provide you the option to specify the DNS on the LAN DHCP side?

If yes, you could specify the DNS there and that will propagate the IP to all the clients that receive a DHCP lease from it.


#3

No, there is no LAN DNS settings on the Zyxel, only WAN DNS.
And what if I disable DHCP on the Zyxel, and enable pi-hole one? (with gateway set to
192.168.1.1)


#4

Try it and see if it works.


#5

It worked with pi-hole DHCP…

But no android devices could connect to the wifi router now !
I googled for it, and some guys have the same issue.
I then try to set the router in AccesPoint mode, but still no luck with android smartphones as soon as I set DHCP in pi-hole.

So I ordered a new router (tp-link C5 archer and hopes it’ll work.
thanks