Android phone using additional (non-Pi-hole) IPv6 DNS

Expected Behaviour:

All DNS requests on my Android phone (OnePlus 3) should be routed through Pi-hole when connected to WiFi.

Actual Behaviour:

Only a small percentage of requests go through Pi-hole.

Analysis:

The Wi-Fi settings only show the Pi-hole DNS. However, when I look in the Ping Tools app, I see the following DNS settings:

  • DNS 1: 2607:f428:ffff:ffff::2
  • DNS 2: 2607:f428:ffff:ffff::1
  • DNS 3: 192.168.1.254

The only configured DNS server should be 192.168.1.254. Where are these IPv6 servers coming from? Is there any way short of manual configuration to get rid of them?

Debug Token:

https://tricorder.pi-hole.net/aaij2nvel6

You may have a better response if you post this on an Android forum.

Are you with Charter / Spectrum?
These seem to be their DNS servers (rns01.charter.com).

If you are indeed contracting Charter / Spectrum as your ISP, your router may hand out these servers for IPv6 address resolution, while using your Pi-hole solely for IPv4.
In that case, your router is lacking a proper configuration for your Pi-hole as local DNS for IPv6.

Indeed, as I was looking through my router config, I saw those DNS servers. And because the Charter router is so lovely, I can’t change any DNS settings on my router. Fortunately, it did have an option to disable IPv6. Now all I see is my Pi-hole’s IPv4 address, and another IPv6 address that seems to be running through my Pi-hole. Perhaps it’s the IPv6 of my Pi? Regardless, it appears to be working now.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.