All set up (it appears) but no ad blocking happening

Expected Behaviour:

Adverts get blocked

Actual Behaviour:

Adverts on suggested test site not blocked!!

Debug Token:

https://tricorder.pi-hole.net/k736lszxg5 !

This is may be a follow on from:


…though I hope not after all the time deHakkelaar spent on trying to get me on the right road…and it worked!..but that was 9 month ago.

For various reasons I stopped using Pi-Hole about 9 months ago. It was working perfectly well then. I now want to start using it again. I thought all I had to do was to turn off the DHCP on my router (ASUS AC68U) and away I go…or so I thought!

The PiHole on my Pi seems to be functioning.

But the adverts are not blocked…

I have no doubt that this is due to forgetting the many lessons that deHakkelaar tried to teach me…where have I gone wrong now?

10.1.1.3 is my Pi running Pi-Hole.

That debug does not exist, can you check and verify or re-run pihole -d please?

Ooops! Sorry! my bad!

Your debug token is: https://tricorder.pi-hole.net/c56k9zslqs

First you need to update to the latest version.

Next, your Pi-hole is not working, it’s offline and there are not domains being blocked as shown by the red icons on the status section and the lack of any numbers other than 0 on the blocking indicators.

Also, the system load and temperatures are very high, what are you running on this Raspberry Pi?

Ooops! you are dead right! Sorry! Now enabled!

Only thing running on this Pi is PiHole…it is quite a hot day here today…29C.

OK, all updated to 4.3.2. and rebooted and other PCs rebooted and PiHole Enabled…still not seeing adblocking…what am I missing?UpdatedPi

New debug token after updates and enabling PiHole.

Your debug token is: https://tricorder.pi-hole.net/w6u1zlcslo

Welcome back.
You dont mention it but when disabling DHCP service on the router, your suppose to enable the DHCP service on Pi-hole as a replacement.
And probably its best to enable the DHCP service on Pi-hole first before disabling the one on the router.
This because some routers re-initialize their interfaces when changing settings causing the clients to temporarily lose network connection en when re-established, try to acquire a new DHCP lease and failing because no DHCP service available yet.

Remember last time, Pi-hole somehow having troubles detecting the right interface ?
Is same happening again ?

ip a

grep '^interface' -A6 /etc/dhcpcd.conf

grep 'PIHOLE_INTERFACE\|IPV[4,6]_ADDRESS\|DNSMASQ_LISTENING' /etc/pihole/setupVars.conf

grep 'interface=' /etc/dnsmasq.d/01-pihole.conf

Before switching DHCP, first wait if the mods/devs can see anything wrong from the debug token why pihole-FTL is failing (showing “Offline” on the web GUI)!

This debug log shows Pi-Hole is working properly.

From a client that you believe should be connected to the Pi-Hole for DNS, from the command prompt or terminal on that client (and not via ssh or Putty to the Pi), what is the output of

nslookup pi.hole

1 Like

Also run below one on a client after you switched DHCP:

nslookup pi.hole 10.1.1.3

And when you have Pi-hole up and running on your RPI you should watch this site.
It brings home security when you’re abroad.

Privacy perhaps, but not security.

~$ nslookup pi.hole
Server:		127.0.0.53
Address:	127.0.0.53#53

** server can't find pi.hole: NXDOMAIN

I thought it was switched on becuause of this…the DHCP box is ticked!

pi@PiHole:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:dd:0c:bf brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:88:59:ea brd ff:ff:ff:ff:ff:ff
    inet 10.1.1.3/24 brd 10.1.1.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::c275:c91:b0e:89c9/64 scope link 
       valid_lft forever preferred_lft forever
pi@PiHole:~ $ grep '^interface' -A6 /etc/dhcpcd.conf
interface wlan0
    static ip_address=10.1.1.3/24
    static routers=10.1.1.1
    static domain_name_servers=127.0.0.1
pi@PiHole:~ $ grep 'PIHOLE_INTERFACE\|IPV[4,6]_ADDRESS\|DNSMASQ_LISTENING' /etc/pihole/setupVars.conf
PIHOLE_INTERFACE=wlan0
IPV4_ADDRESS=10.1.1.3/24
IPV6_ADDRESS=
pi@PiHole:~ $ grep 'interface=' /etc/dnsmasq.d/01-pihole.conf
interface=wlan0

This was run directly on the client OS, and not via a ssh or Putty session to your Pi? If so, what DNS server resides at 127.0.0.53?

I have no idea…as far as I am concerned all my internal IPs are 10.x.x.x!!!

that was run on my main PC which is connected directly via cable to the router.

Did you type the command directly into the command prompt on the Windows machine, or were you connected to a ssh session to the Pi at the time and the command was actually run on the Pi?

From the command prompt on the PC, what is the output of this command:

ipconfig /all