All set up but only the router is shown as a client

I imagine this is me being a noob, so first of all thank you for all the support on here already ...

I've got my PiHole working, and it is wired directly into my router. The dashboard only reports the router itself as a client, rather than reporting the other devices on the network.

Now it looks like PiHole is happily blocking all sorts of unwanted traffic, but I'd quite like to see which clients the requests are coming from. I presume I need to do something else in setup, but am a bit wary because I've not really used non-Windows/Mac platforms since about 1999 ...

Hello @lucullus, welcome to the Pihole Community.

You have to setup your router in a way that it distributes pihole's IP as DNS Server via DHCP to clients. If you have changed that settings, you have to disconnect the clients once to pick up the new settings provided by your router.

1 Like

Hmm. I have a recently purchased Unifi Dream Machine (hello, reliable wifi for lots of devices), but I'm not sure what I'd need to do on the DHCP. I have set the DNS on the wireless network, which I imagine may imply that the PiHole isn't doing DNS for wired connections, either.

(I quite understand if this is all out of scope for this forum, btw!)

Not sure about the web interface for the Dream Machine, but in my Unifi Controller for USG you have to set it up under "Networks"

See the "DHCP Name Server" is set to manually and is the IP of my phole,

1 Like

My interface looks just like that - many thanks! :smiley:

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.