All queries showing up from router and localhost

Hi,

I know this has been asked many times before but all the fixes that I have seen don't work for me. I just setup a Pi-hole on a Pi Zero and it is working well but all the queries are either coming from the router's ip (192.168.1.1) or localhost.

Things I have tried(the expected behaviour is the same for all of these, queries show up from device's ip):

Pi-hole DHCP on and router DHCP off (DNS left alone on router settings)

Result

No queries appearing.


Pi-hole default settings and router with DNS set to pi-hole's ip

Result

Pi-hole works but most ip's are coming from router and a few are coming from localhost.


Pi-hole with DHCP on, router DHCP off, and router DNS set to Pi-hole.

Result

Pi-hole works but most ip's are coming from router and a few are coming from localhost.


More details

OS: Raspberry Pi OS lite.
Internet connected via: Ethernet (using micro usb to ethernet adapter)
Debug Key: https://tricorder.pi-hole.net/ia9z6jofps
Router: Verizon Fios (I think it is a Quantum gateway, not sure what model though)


Thanks!

Edit: Accidentally posted this while it was incomplete, it is fixed now.

You distribute your router's IP as DNS server via DHCP. You need to set Pi-hole's IP as DNS server in your router's DHCP settings.

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
   Scanning all your interfaces for DHCP servers
   Timeout: 10 seconds
   
   * Received 312 bytes from eth0:192.168.1.1
     Offered IP address: 192.168.1.174
     Server IP address: N/A
     Relay-agent IP address: N/A
     BOOTP server: (empty)
     BOOTP file: (empty)
     DHCP options:
      Message type: DHCPOFFER (2)
      server-identifier: 192.168.1.1
      lease-time: 86400 ( 1d )
      netmask: 255.255.255.0
      router: 192.168.1.1
      dns-server: 192.168.1.1
         domain-name: "fios-router.home"

Your clients may have still been using your router's settings.

You should note that any DHCP changes will only be picked up by a DHCP client of yours when it requests or renews a DHCP lease.

According to your router's setting,

*** [ DIAGNOSING ]: Discovering active DHCP servers (takes 10 seconds)
(...)
      lease-time: 86400 ( 1d )

that will happen for persistently connected devices after 12 hours (half the lease time for a renewal) at the earliest.

In order to put those settings to effect for a client immediately, you need to force that client to request a DHCP lease, e.g. by switching off and on a device's wifi access or by power-cycling a device.

1 Like

Thank you for your replies!

You distribute your router's IP as DNS server via DHCP. You need to set Pi-hole's IP as DNS server in your router's DHCP settings.

For step one should I just enable DHCP on Pi-hole and disable it on my router? And for the second part I don't see any DNS settings under DHCP. My router settings look like this (there are some more settings pages I can show if needed): image

As for Bucking_Horn I think I found a setting to refresh the DHCP lease but I can also just turn off and on wifi for my devices: image

Thanks!

Fixed it! I just needed to turn on Pi-hole DHCP, turn off router DHCP, and turn off and on my device's wifi like Bucking_Horn said.