After upgrade to v4.0 stopped blocking


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Expected to work as previous version

Actual Behaviour:

Not blocking ads despite of the fact that shows everything is working

Debug Token:

w998t88drv


#3

Your debug log shows the Pi-Hole is blocking domains as shown below.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] scripts.adrcdn.com is 0.0.0.0 via localhost (127.0.0.1)
[✓] scripts.adrcdn.com is 0.0.0.0 via Pi-hole (192.168.4.4)
[✓] doubleclick.com is 216.58.202.238 via a remote, public DNS server (8.8.8.8)

Is the problem you are seeing limited to one client, or is the problem across multiple clients? Can you post a screen shot of what you are seeing?


#4

That’s what I call a quick reply!

I’ve disabled ipv6 on my desktop and it’s now blocking. I have ipv4 and ipv6 enabled on pi-hole but it does not block ipv6.

What can be done?

Thanks


#5

An additional comment, router is getting IPv6 from provider but LAN DHCP for IPv6 is disabled, anyway all deviced are receiving local IPv6. I think this might be causing the issue, that’s why I’ve disabled IPv6 on desktop to test and worked on ipv4-only mode.


#6

According to your debug log, it is blocking IPV6:

*** [ DIAGNOSING ]: Name resolution (IPv6) using a random blocked domain and a known ad-serving domain
[✓] bs.serving-sys.com.76263.9639.302br.net is :: via localhost (::1)
[✓] bs.serving-sys.com.76263.9639.302br.net is :: via Pi-hole (2804:.....)
[✓] doubleclick.com is 2800:3f0:4004:809::200e via a remote, public DNS server (2001:4860:4860::8888)

#7

It shows it’s blocking but it does not block. I’ve re-enabled ipv6 and the ads are back on again.


#8

Your router is likely providing an IPV6 DNS to clients and that bypasses Pi-Hole. If you don’t need IPV6, just leave it off and you’re all set.


#9

I’ve disabled ipv6 on router’s config. It’s now working.

Cable company router sucks big time imho.

Thanks for your support. Keep up the outstanding job!


#10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.