Ads not being Blocked on Android

So I have the pi setup as a simple DNS server. I’m not using it for DHCP. Seems to work on everything except for my Google Pixel 2 running Android 10.

How do all the client devices know to use the Pi as a DNS server? Reconfigured your ISP router to issue it vai DHCP?

I presume the phone is connected to the same network via wifi and its not fallen back to using mobile data?

FIrst thing I would do on the phone is go into my wifi settings and for testing purposes set your IP and DNS statically and also disable mobile data temporarily

I have the router of my network set to use the pi as it’s DNS.

Sadly there is no way to static an IP in Android 10 unless maybe I root the device but I do not wish to do that

really ?

so they’ve done away with the long press on the SSID name under WiFi and click on Modify Network, SHow Advanced Options?

Bit of a retrograde step!

Yes that’s how you should do it or use DNSfilter to force devices to use the pihole dns on the router

Mikeyw64, I lied they just hid it deeper in the wifi options. Now if you wanna set a static you have to go into the wifi hit the pencil as if to change the password then advance options then click DHCP select static. I’ll have to try it when I get home later

1 Like

A more comfortable way to configure all DNS on your Android device is Blokada, also aviable on F-Droid.
You can configure once your pi-hole as custom-DNS-server and then it changes the settings too.

But how would that work outside your home Network?it runs on VPN and you’d need your home VPN to have pihole act as dns resolver

Check that private dns is turned off. If it’s set to automatic, it may bypass your pihole.

I’ve tried that still no results

You may have to block a few ip’s

8.8.8.8
8.8.4.4
2001:4860:4860::8888
2001:4860:4860::8844