Admin page returns 403 Forbidden; new install

This is a brand new pi-hole install on a raspberry pi. I used the install script.

Script seems to have worked. Quickly scrolling text, but I did see some "red".

Debug Token:


After install, I tried to load the admin page, both locally and from another on same network. Both browsers return "403 - Forbidden"

This is the output from: curl -I http://localhost/admin/
HTTP/1.1 301 Moved Permanently
Location: http://localhost/admin/
Date: Thu, 22 Mar 2018 18:01:11 GMT
Server: lighttpd/1.4.35

Let me know if you need me to try anything.
Thank you!

Can you also try

curl -I http://localhost/admin

without trailing /

What's your operating system? Fedora?

My apologies, my earlier error was without the trailing / (I included with it here by mistake)

If I include a trailing "/", then I get:
HTTP/1.1 403 Forbidden
Content-Type: text/html
Content-Length: 345
Date: Thu, 22 Mar 2018 18:39:12 GMT
Server: lighttpd/1.4.35

The OS is Raspbian 8 (jessie)

First restart your Pi and check if you can access the website with a browser.

Then please read the notes about Jessie in this blog post

The reboot fixed the "admin page not accessible" problem. -- thanks!
And thanks for the heads-up about whitelisting issue with Jessie.

However, I see I have a new problem ... "FTL offline" and no stats are showing.
But let me look into this. I see a help page here that might help:

Thanks again all -- keep up great work!

This was also the solution in another thread. Same problem, same solution.

Sorry, but I can't seem to fix this.
Maybe I'm not seeing the connection to the solved thread.

In this case, I cannot get dnsmasq to start. DNS service is not running. And so FTL is not up either.
I tried a new debug token. But got an error trying to upload the debug log. (w/o DNS)

Here is the local, sanitized debug log:

Quick update:

I found and commented out log-queries=extra
Then restarted. Okay, DNS (dnsmasq) back up and running.

Now: Status: Active. FTL offline

No stats show -- just 'spinning arrows' (but don't timeout).

New debug token: ua2jnhr4bq

Leave it uncommented but remove =extra


Ok. I uncommented, but removed the "=extra"
Then rebooted.

Problem persists. :frowning: Active status, but FTL offline.

Can you send us your entire pihole-FTL.log?

cat /var/log/pihole-FTL.log | pihole tricorder

Interesting... I typed the full command and I get:

cat: /var/log/pihole-FTL.log: No such file or directory
Use netcat.

There is no /var/log/pihole-FTL.log
There is a pihole.log and pihole.log.1

It looks like your still on dnsmasq v2.72 and Pi-hole v3.3 so it doesn't seem you followed either of these solutions (from the link @mibere posted):

Okay - I picked option 2: upgrade dnsmasq to 2.76. Done.

New debug code: 2a51v96m7c

After a reboot, I'm still stuck on "FTL offline" on Admin page.

Above all, thank you for your patience with me, and continued help.

You still have some issue with the install:

Mar 23 01:51:04 dnsmasq[572]: failed to load names from /etc/pihole/gravity.list: No such file or directory
[✗] pihole-FTL daemon is unknown

Try a pihole -r > Repair now that you have the right version of dnsmasq

BAM! It worked!! Yea!


edit: You rock! :smiley:

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.