Admin interface rendering as text only - Apache

Instead of disabling Apache2, I just set the lighttpd server to use another port in the /etc/lighttpd/lighttpd.conf file. Solved! I can now use both apache2 and pihole.

You are probably missing the PHP support (for Apache) if you pages are rendering as text only.

Can you upload a debug log so we can take a look ?

You can move lighttpd to a different port and it will co-exist with Apache. The setting is in /etc/lighttpd/lighttpd.conf .

Note that your local changes will be overwritten with a Pi-Hole repair or update.

Thanks RamSet. Here is a debug log: https://tricorder.pi-hole.net/lcdfi1qifv

You have 2 options :slight_smile:

  1. you can install the (missing?) php support for apache
  2. you can edit /etc/lighttpd/lighttpd.conf
    and change the server.port = 80 to some other port of your choice.
    This will make the /admin/ interface available via http://pi-hole:PORT/admin/

2 is more of a workaround and not the most optimal thing for your raspberry, as you have all those resource intensive things there too.

1 Like

YAY!
I got it to work!
The lighttpd was located unter /etc/lighttpd/lighttpd.conf
I changed the port to 88 and when I accessed pihole:88/admin, it worked!

Thank you all so much for your suggestions!

Good idea to install php for my apache too. I will look into it!