Adlist with ID 1 was inaccessible during last gravity run

I keep getting errors after adding adlist. I using the green highlighted texts lists from firebog. Ive deleted them all and still getting errors when I use the list that came preinstalled. Oddly pihole still seems be working on the phones connect to the wifi, but my PC still gets them.

Expected Behaviour:

adlist to update with minimal errors

Actual Behaviour:

I keep getting errors

Debug Token:

_ _

The message is just a warning (not an error) saying the list was not accessible during the last update:

   Last gravity run finished at: Wed May 24 11:46:07 PM EDT 2023

The list wasn't updated, but you still have the previous list. Nothing is broken.

Try to Update Gravity again.
Maybe the list was temporary unavailable when you tried to update it.

You need to check if your PC is using Pi-hole as DNS server.

In the Pi-hole web interface go to Adlists and you will see that list in there (likely at the top). Click it. Does it load up in a browser (it will be a huge list of domain names) or do you get an error, and if so what does it report?

In a terminal window try the command below. What does that give?


Server: "omitted"
Address: "omitted"

Non-authoritative answer:
Addresses: 2606:50c0:8003::154

If you are able to open the list by clicking on it then it is available and you can reach it from your ISP. And your nslookup results are all correct for the github domain.

If you go to Adlists again you'll see an error icon next to the list and if you click it you'll see what the issue was (it was unavailable). As for the message in Tools > Pi-hole diagnosis, an adlist being offline during an update causes the warning message to always be present in there until the adlist is available or removed from Adlists. So you can expect that to be shouting at you for a little while. That's probably what you're seeing there.

Try what @rdwebdesign suggests as it may have just been offline temporarily and is back now.

ive been trying to update the gravity list and keep getting:

[x]dns resolution is currently unavailable
[i]time until retry:120

then after the countdown
[x]dns resolution is not available

tried reinstalling armbian and pi from scratch and still getting DNS issue

what should the first line nameserver be?
changing it allowed me to update the gravity list

still having trouble getting my PC to use the piDNS...why idk everything is pointed to the pihole pi address

Is it? In your earlier reply you wrote:

Server: "omitted"
Address: "omitted"

Run that command from a client on your network which should be using Pi-hole. What do you get for Server and Address?

those were omitted by me, heres the full log

Address: 2001:558:feed::1

Non-authoritative answer:
Addresses: 2606:50c0:8002::154

There appears to be two problems.

Just double checking – you ran that on your PC? If so, your PC is not using Pi-hole for DNS, it's using Comcast's DNS. I assume that Comcast is your ISP which implies that the DHCP server in your router is handing out that DNS server.

You need to modify your router's DHCP settings so that it is handing out only the Pi-hole's IP address for DNS. You may want to disable IPv6 too, at least temporarily while you're diagnosing this.

Another option here is to disable the DHCP server in your router and enable the DHCP in Pi-hole in Settings > DHCP and let that handle it, since it defaults to itself as DNS server for clients.

The other problem seems to be that, out of the box, your Armbian installation is having its nameservers set to Comcast's IPv6 DNS servers but seemingly no IPv4 addresses. It appears that you don't have an IPv6 path to those external servers and so name resolution fails, and this is the cause of your Pi-hole terminal error and your adlist failing to be retrieved. You've worked around this by manually adding in Cloudflare's IPv4 server, and since you do have IPv4 connectivity out, that works and gives you name resolution.

It's likely that somewhere in the Armbian installation you can configure or override this setting and ensure that it has a working IPv4 server as standard.

It's not clear how this is all working together but some things you can try are, again disabling IPv6 in your router temporarily to ensure that IPv4 is the only scheme available and thus getting that working initially. If you are using a Raspberry Pi then perhaps try a standard Pi OS Lite image to confirm a working setup, since the workflow for that distro is standard on that board.

1 Like

doubled checked my router and it was on the wrong dns, that has been corrected. but the PC still wont work right. strangely, it'll show the hits from my torrents but no the sites visited.

with that resolv.conf file, what does the average users resolv.conf file look like? thinking about doing another clean install.

Try taking the PC off and on the network to force it to renew its lease and pick up the updated settings. Then try again, re-run the nslookup command as a handy check. No need to post the output, just see if it's using Pi-hole now or if it's still using Comcast.

resolv.conf commonly has a couple of nameserver entries, example below. These are the nameservers used by the OS (on which Pi-hole is just one of many things installed), not to be confused with the upstream DNS server settings used in Pi-hole's own DNS config in Settings > DNS.

/etc/resolv.conf example


Often it's being managed by an external service such as NetworkManager; if so there tends to be a comment on the first line advising. If you change it manually, as you did, it may revert back after some time or after a reboot as the service updates it. A search of this forum will likely find tips on how to deal with that. The Pi-hole installer does a good job of integrating your settings during initial setup.

prior to using the orange pi as my pihole, i was running pihole through docking and install it with a script, could this be causing the issues preventing my PC from using the orange pihole dns?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.