AdBlock prevents ads while Pi-hole allows. Is Pi-hole misconfigured?


#2

Are you sure you have only the Pi-hole in your DNS settings? Does this site say you have full IPv6 internet access? http://ipv6-test.com/


Don't know if I'm doing it right (Pi-hole Installation)
#3

My router is set to Pi-hole as its primary DNS server. Test gave me a score of 17. Both IPv6 and IPv4 are connected it says.

Thanks


#4

What is the output of these commands on both the Pi-hole and your client device?

nslookup mgid.com
nslookup steepto.com

#5

Windows 10 says this:

PS C:\WINDOWS\system32> nslookup mgid.com
Server: UnKnown
Address: fe80::1
Non-authoritative answer:
Name: mgid.com
Address: 64.58.116.132
PS C:\WINDOWS\system32> nslookup steepto.com
Server: UnKnown
Address: fe80::1
Non-authoritative answer:
Name: steepto.com
Address: 64.58.116.132

While in Debian it gave the same output for both of these:

Server: 127.0.0.1
Address: 127.0.0.1#53
Name: mgid.com
Adress: 192.168.1.90

Server: 127.0.0.1
Address: 127.0.0.1#53
Name: steepto.com
Adress: 192.168.1.90


#6

Your windows machine is not using Pi-hole (at least on IPv6)


#7

So if you don’t mind can you help me set that up?

Thanks


#8

Follow the manual instructions:


#9

My Pi-hole is connected via a Virtual Switch. So, I’m unsure to change the IP settings since in “Network Connections” there is both “Network Bridge” and "vEthernet (PiHole Switch).

For Network Bridge, IPv4 is set to 192.168.1.90 and 8.8.8.8, whereas there was nothing for IPv6. So I entered “fdb8:8d7:b38a:3d00:d9aa:4e53:a54d:42c9” and " 2001:4860:4860:0:0:0:0:64".

For vEthernet (PiHole Switch), there is nothing set for IPv4 while for IPv6 there is only “fe80::1” as Preferred DNS server and nothing for Alternate DNS server.

Please see the screenshot.Capture


#10

ifconfig outsputs this:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.90 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::215:5dff:fef7:eb06 prefixlen 64 scopeid 0x20
inet6 fdb8:8d7:b38a:3d00:d9aa:4e53:a54d:42c9 prefixlen 64 scopeid 0x0
inet6 2407:7000:841f:9800::3 prefixlen 128 scopeid 0x0
inet6 2407:7000:841f:9877:1f24:84a3:2af:f8f3 prefixlen 64 scopeid 0x0
ether 00:15:5d:f7:eb:06 txqueuelen 1000 (Ethernet)
RX packets 1233 bytes 372616 (363.8 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 984 bytes 293128 (286.2 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (Local Loopback)
RX packets 261 bytes 22726 (22.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 261 bytes 22726 (22.1 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


#11

Which route does traffic use? Try setting all of the DNS servers to only Pi-hole.


#12

I set everything to use Pi-hole as Primary DNS and Google as secondary.

nslookup steepto.com gives the same output.

Server: 127.0.0.1
Address: 127.0.0.1#53
Name: steepto.com
Adress: 192.168.1.90


#13

That means that it should be blocked. Have you tried flushing your browser’s DNS cache?


#14

will give it a try and reply

thanks


#15

ok now it seems the ads are blocked. it shows “loading” but no more vulgar ads. But if I type in steepto.com into my browser, it loads. I guess, this is pretty much all we can do.

Thanks


#16

It shouldn’t be loading since that nslookup output showed that it was getting blocked. Did you enter www.steepto.com? Also try flushing your browser’s DNS cache.


#17

I entered steepto.com. I had flushed the DNS. What might be the issue?


#18

What’s the output of this command on both the Pi-hole and your client device?

nslookup steepto.com

#19

it is:

Server: 127.0.0.1
Address: 127.0.0.1#53
Name: steepto.com
Adress: 192.168.1.90

and in Windows 10, it is:

Server: ssl.google-analytics.com
Address: fdb8:8d7:b38a:3d00:d9aa:4e53:a54d:42c9

Name: steepto.com
Addresses: fdb8:8d7:b38a:3d00:d9aa:4e53:a54d:42c9
192.168.1.90


#20

It looks like it is correctly blocking the site. Did you flush the browser’s DNS cache?


#21

I have removed Hyper V, so once I get it back on, i’ll reply. Thanks