Activate IPv6 on Raspbery Pi zero w possible?

Hi there,

I have pi-hole an a RBPi zero w running (including an ethernet-adapter > LAN-connection) and just installed PiVPN/Wireguard. This worked pretty good. Pi-Hole is still running, everything's fine so far...

Now I'm struggling with finding the IPv6-address which I need to enter on the port in my router? I only find a IPv6 address with 6 chapters, but I need 8.
Can you assist or is the problem related to the RBPi zero? Thanks

With "chapters" I assume you mean the blocks between colons? Does the IPv6 address you do find look something like this?: fe80::0123:4567:89ab:cdef
Just fill the space between the double colon with zeros to get to 8 blocks like this: fe80:0000:0000:0000:0123:4567:89ab:cdef

Thanks the fast reply. That was exactly what I was looking for. I will give it a try later.

I entered the address as you suggested and could safe it.
Problem is now different, don't know if this has to do something with this problem. I want to enter a new account in Wireguard and with scanning the qr-code out of the ssh-connection I get this message: "Kann Tunnel nicht importieren: Unbekannter Abschnitt in config". Something seems to be missing...

Why are you using IPv6 between Pi-hole and the router? It's a local connection, don't overcomplicate your setup with things you don't need.

But I thougt I need this connection when using Wireguard.

Not that I know of. What guide are you trying to follow?

Well, If I open Port 51820 I can only do this in my connectbox using IPv6

Why are you opening ports? What guide are you following.

There is no such thing as an IPv6 only port.

I followed several instructions. The Installation worked well, but the setup is Not working now. Do you have a guide I should use?

What is it that you are trying to accomplish?

I want to get a vpn-connection to my pi-hole and use its setting with my smartphone outside of my network


I guess I have to do it from stretch again...

I just gave it a try with your mentioned documentation - result after running:

sudo apt-get install wireguard wireguard-tools wireguard-dkms

E: Paket wireguard kann nicht gefunden werden.
E: Paket wireguard-tools kann nicht gefunden werden.
E: Paket wireguard-dkms kann nicht gefunden werden.

Is this a problem because I use a RB Pi zero w for my pi-hole?

For an RPi Zero with its ARMv6 CPU, you'd have to compile Wireguard yourself. Our guide details the necessary steps.

You are talking about these instructions, right?

Almost - you shouldn't start at that point, but read and follow the entire section on how to Compile WireGuard from source.

1 Like

Ok, got it. Will give it a try asap. Thanks
Hope it make sense to run it on a RPi zero. .

Took me a few days to try it.
I installed wireguard as mentioned starting from Installing the server components over Compile WireGuard from source. So installation of the server was successfull. I even thought the next page ** Adding a WireGuard client** was successfull.
Problem is now, when I scan the QR-Code after sudo qrencode -t ansiutf8 -r "/etc/wireguard/${name}.conf" I get the following message in the wireguard app: "Kann Tunnel nicht importieren. Unbekannter Abschnitt in Config"
Any ideas? Surely my fault in way, but don't know where to search...