Accessing https://ici.tou.tv (blank page problem)


#1

I would like to access https://ici.tou.tv.

Sadly, https://ici.tou.tv makes many uses of badly written scripts. What has happened to me, is that the whole site goes blank when using pihole. Using the Tor browser, I was able to see the site again (the Tor browser does not use pihole).

Could anyone else try https://ici.tou.tv and see if they get the same result?

And if you get the blank page, is there a work-around?

ta, t.


#2

You can just whitelist that site?


#3

Yes, I tried ‘pihole -w https://ici.tou.tv’ and that gave no result.

Do it go blank for you too?


#4

Try ‘pihole -w ici.tou.tv’ (no http:// header!)
Or use the GUI.


#5

pihole -w ici.tou.tv
[i] ici.tou.tv already exists in whitelist, no need to add!
[i] ici.tou.tv does not exist in blacklist, no need to remove!

Thus, do you get a blank page when you try to access https://ici.tou.tv ?


#6

No, I don’t get a blank page and I have neither white- nor blacklisted the site. Seems to be a french-speaking TV site.
What problems are you experiencing? You speak of badly written scripts, but things look smooth here.
I can’t play any shows - since I am not in France (or Canada).


#7

I did not get a blank page. I got a blank page as soon as I allowed in NoScript to run the script from that site.

I think they see that I am not living in Canada and are not interested any more. :rofl:


#8

Even with a Canadian IP-number, the blank page happens.


#9

I got the problem on Linux Mint 18.3 (with four different browsers), with Linux Mint 19 (five different browsers) and on Ubuntu 18.04 (three different browsers).

On the Ubuntu box, I changed the /etc/resolv.conf from the Pihole raspberry pi to 1.1.1.1 directly. And it worked just fine.

Thus, there is something not working between https://ici.tou.tv and Pihole.


#10

Maybe it you need a Québec IP address. You know how sensitive they are. :wink:

[ maybe shooting in my own foot ]


#11

C’mon, stop trolling.

And yes, it’s a Montreal IP-number.


#12

They are showing me a blank page so I have to look behind the screen to see what they want to do:

	<script type="text/javascript" src="https://services.radio-canada.ca/media/player/client/toutv_beta" async></script>
	<script type="text/javascript" src="https://www.googletagservices.com/tag/js/gpt.js" async></script>

Whitelist: www.googletagservices.com

I used Brave browser and disabled all protections and disabled pi.hole and got:

Conformément aux droits de diffusion, le contenu sélectionné n’est pas disponible dans votre pays.

So it must be working then for you.

Bonne chance

update: I tried it later with pi-hole enabled again and it still worked.

Direct link: https://ici.tou.tv/elections-quebec-2018-le-debat/S01E01?lectureauto=1


#13

With Pihole, this is what I am getting with Brave.

All this is not only Brave, but on all of the browsers. OS is Mint 19.

When I put the dns in /etc/resolv.conf to 1.1.1.1, I can make use of the site again.

t.


#14

On the right top you see a orange lion head and click that. Disable shields and try again.


#15

Nope, that still did not work.

I have tried https://ici.tou.tv with Pihole on six different browsers. All the same result, the page goes blank.

If I set the dns in /etc/resolv.conf to a non-pihole dns, it works on all six browsers.


#16

Dit you whitelist www.googletagservices.com in pi-hole?

Removed


#17

Yes, I have tried whitelisting and blacklisting googletagservices.com and I get the same result: the blank page (which initially loads for a second or two, then goes blank).

This has happened in: Mint 19, Mint 18.3, Ubuntu 18.04 and in ChromeOS. Same problem. When I don’t use the pihole dns (changing the /etc/resolv.con to 1.1.1.1), then I don’t have the problem. So far, it only happens on this one site, https://ici.tou.tv

I’ll keep at it. It’s a very strange problem which should not be happening.

t.


#18

So how does your Pihole query screen looks when you have visited that “shy” page? Don’t forget to flush first the cache of the client.


#19

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.