Wrong token error on every setting change


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

I try changing either a blacklist setting, or a DHCP setting, or basically any setting. I expect
settings actually being changed thru the web interface

Actual Behaviour:

Getting the error ‘wrong token’ at every try.

Tried different browsers, also tried different webservers. Current one being Nginx. Also tried turning basic authentication off and emptying browser caches. Checked the security settings for accepting cookies.

Debug Token:

bnilob1a87


#3

Change back to lighttpd for now to minimize things that could go wrong. Once you do that, check /var/log/lighttpd/error.log and journalctl -u lighttpd for any errors.


#4
Error.log:
2018-12-03 22:36:14: (log.c.217) server started
2018-12-03 22:36:30: Wrong token
2018-12-03 22:38:14: Wrong token

Journal has no new entries after trying to post some changes on the web interface. Just this:

dec 03 22:36:14 webserv systemd[1]: Starting Lighttpd Daemon...
dec 03 22:36:14 webserv systemd[1]: Started Lighttpd Daemon.

Ill post a new debug: somfiueqdw


#5

Your web server (PHP) seems to be having an issue holding the session open. Check the cookies to see if it’s being assigned a new PHP session cookie on every refresh.


#6

It seems there are no session cookies being served at all. At least thats what i gather from the web inspection tool in Safari. Any advice on php.ini cookie settings?


#7

I’m not certain of the specifics, so you may find better advice via Google.


#8

Toyed around with different php.ini settings to no avail. What befuddles me, is the lack of debug or logging concerning this error. It’s rather generic. This makes it very tough to troubleshoot.


#9

Works. The php sessions save path wasn’t writable for my PHP-fpm process-owner.
Chmodding it, fixed it. Thanks for steering me in this direction.