Whitlisting not working Pi-hole Version vDev


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

Should be whitelisting.

Actual Behaviour:

Not whitelisting. Tried via web UI, still blocks, tried via ssh after removing from web UI whitelist and adding via ssh, still blocks. g.api.mega.co.nz is the issue. It allows AAAA but not A.

Debug Token:

jqd0yawwii


#2

Hey sorry to see you’re having these problems. Could you try a couple steps for me please?

  1. whitelist a site from the WebUI or CLI (whichever you use more often)
  2. wait about 30 seconds to make sure the script completes the on the CLI grep "domain" /etc/pihole/gravity.list
  3. paste the result of the grep here

#3

It comes back empty.

pi@raspberrypi:~ $ grep “g.api.mega.co.nz” /etc/pihole/gravity.list
pi@raspberrypi:~ $


#4

So that reply is telling us that the domain is not found in Gravity, and will not be blocked.

Did you clear the DNS cache on the device you are attempting to access this URL on after whitelisting?


#5

It’s being accessed through rclone mount on an unraid server.

2018/07/13 12:39:40 ERROR : mega root ‘’: Statfs failed: failed to get Mega Quota: Post https://g.api.mega.co.nz/cs?id#######################: dial tcp 192.168.0.33:443: connect: connection refused


#6

If I disable pihole, it will allow the connection.


#7

Is there anything blocking port 443 on the device? sudo netstat -tulpn | grep 443


#8

comes back empty


#9

I’m using the dev so I could implement dnscrypt… I can go to other whitelisted URL’s fine.


#10

Can you in one terminal window run pihole -t to tail the log live and in a second trigger the access attempt to see if it is something pihole is blocking?

as it is port 443 there might be some black magic occuring but im a little perplexed at this moment.


#11

comes up red inside gravity.list with lu.api.mega.co.nz


#12

but inside the UI it’s showing it’s blocking g.api.mega.co.nz is 192.168.0.33 which is the piholes IP


#13

is this whitelisted as well?


#14

No, didn’t realize it was needed till right now. Trying it out.


#15

No worries here to help :slight_smile:


#16

That was the problem, seems to be working fine now. I’ll give it 24 hours :smile:


#17

Awesome. Happy to hear it