Whitelist button doesn't work in Query Log page

Expected Behaviour:

Clicking the whitelist button adds that domain to the whitelist.
OS: Ubuntu 20.04
Pi-hole version: 5.1.1

Actual Behaviour:

Domain is not added to whitelist.

Debug Token:


What domain were you trying to add to the whitelist?


Have to ask the usual question, have you cleared you browser cache and cookies?

Browser cache, yes, cookies, no. I'll try that now.

Clearing cookies didn't change anything, unfortunately.

Is there an error or screen output when you try to whitelist that domain?

No errors, it says "Successfully added".
Console error (although looks unrelated):

We don't have any external fonts?

I'll try incognito and see what happens.

I think this is a browser setting issue.

Ok, so those font errors are caused by the Grammarly extension, so that's solved.
I can successfully black/whitelist domains in incognito mode, but not otherwise.
Disabling all extensions in "normal" browsing mode doesn't work though, I'm at a loss.

Edit: also didn't have this problem before v5.1.1, just noting that, kind of odd

It sounds like this is a browser issue.

After I updated to 5.1 from 5.0, the Whitelist and Blacklist were displayed as empty. I was ready to declare a bug when as a last grasp at the straw, I forced the browser to reload the page. Success as the Whitelist was displayed. Repeated force reload with Blacklist and Dashboard pages and now all is well with PiHole and me.


Why would the issue appear after an update though?

Well it works now, I'm not sure what changed!

Different javascript in the new version, and the browser still has the old javascript. Clearing the browser cache forces a reload of fresh code.

Ah ok, thanks. It's working now, I'm not sure why but oh well.

I can report that flushing the cache on Chrome does not always work. It looks like a Chrome bug. I had a similar issue with Pi-hole v5.1:

Firefox was perfectly fine (no force-refresh required).

Google Chrome was causing problems:

  1. Cleared cache + deleted cookies + deleted local storage to no avail.
  2. Tried in incognito mode: Everything worked fine.
  3. Went back, deleted everything once again, still no joy.
  4. Force-refreshed (Ctrl+F5), still not working.
  5. Renamed Chrome's profile folder (/home/user/.config/google-chrome/default), everything worked. :white_check_mark:
  6. Renamed back the profile folder - again failed.
  7. Having been annoyed. Came back the next day - issue resolved :laughing:

Same kind of issue. It's been working for the past 19 days up until now.

Click on Blacklist on a DNS query page, I get a popup saying it's been blacklisted. But doesn't appear in the blacklist. It does bug occasionally by adding it to the black list page but I am still able to access the website

I've rebooted the PiHole, tried three different browsers, cleared all data, cookies and so
All up to date, disk space is not full.

Command line of pihole -b google.com works fine.
Adding the record manually works via the WebUI also works.

Debug: https://tricorder.pi-hole.net/y3u1vlq4tz
Browsers: Firefox / Palemoon / IceCat