What should be in resolve.conf

Hi there,

I recently changed my internal network IP due to a new ISP with the same internal IP.
I performed pihole -r and configured pi-hole.

However, next to pi-hole I also have DNScrypt installed, but I am not sure if this is working as intended.
If I look at etc/resolve.conf I see:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 8.8.8.8
nameserver 8.8.8.8

In pihole I have set ip as Upstream DNS Servers: 127.0.0.1#54 which is the port DNScrypt is at.

What should be in resolve.conf? Am I doing this correct?
Below output of dig:

; <<>> DiG 9.10.3-P4-Raspbian <<>> debug.opendns.com txt
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11744
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;debug.opendns.com.             IN      TXT

;; AUTHORITY SECTION:
opendns.com.            49      IN      SOA     auth1.opendns.com. noc.opendns.com. 1562667043 16384 2048 1048576 2560

;; Query time: 11 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue Jul 09 12:51:45 CEST 2019
;; MSG SIZE  rcvd: 92

Thank you in advance.

Cheers,

When Pi-hole is started and then running it should only contain this nameserver:

nameserver 127.0.0.1

The port used by DNScrypt is between Pihole and that program.

Strange that it should 2 times 8.8.8.8.
How should I fix this?

You could try restarting your Pi-hole and see if then correct. Otherwise you have to change it by hand.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.