What is the CORRECT way to get local hostname resolution without pihole as DHCP?

As an example, I just got it to work again by doing:

sudo pihole -a hostrecord [hostname]

But I'm sure it'll stop working again, later.

This is done on the Pi in file /etc/hosts. If you have a printer, for example, the line entry in the /etc/hosts file could be: Printer

Note that for this to be correct, your DHCP names have to be reserved (or static) from the router.

That is the very first thing I did. I use static reservations. I can of course ping from the pi.

It works on the clients... Until it doesn't. I'll see if it's something else on my client.

The method I use is described here section Q/A - "Why so many local requests?".
I've been using this for over a year now, pihole is NOT involved in this, I simply use a dnsmasq feature (does also work with pihole-FTL - pihole 4.0).

For this to work, you need to:

  • have static DHCP addresses (using the MAC address) configured on the router (or whatever you use to provide DHCP)
  • have a domain configured in your router.
    I use pfsense, the domain is configured under system / general setup / domain. A lot of routers allow you to specify a domain, this will be distributed, using DHCP, to all clients.

On windows, You can verify you have a domain name by using "ipconfig /all", look for
"DNS Suffix Search List. . . . . ."

The solution works with ipconfig and nslookup:

ping y50

Pinging y50.localdomain [] with 32 bytes of data:
Reply from bytes=32 time=1ms TTL=128
nslookup y50
Server:  raspberrypi.localdomain

Name:    y50.localdomain

reverse lookup:

Server:  raspberrypi.localdomain

Name:    y50.localdomain

My Ubiquiti USG adds the .local suffix for my domain. I use static reservations from the USG.
I am using Ubuntu 18.04 on my laptop, and have tried adding my domain suffix (which I shouldn't need - before the pihole, the USG appended the suffix automatically to any DHCP clients).

As of now, nslookup is showing the correct results, and I'm able to ping from my laptop... but from my mobile phone, I have to disconnect/reconnect my wifi connection to get to pi.hole - every time.

I might be looking at a problem outside the pi-hole; but I appreciate the help!

Hey guys. I was gone for a while; returned and saw that although any device with the .local suffix is browsable from my laptop, pi.hole still does not resolve! The /etc/hosts file on the pi-hole looks like: localhost
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters pi.hole yochai-server pi.hole

As you can see, the custom entries are at the bottom (I even appended the static IP of the device, though I don't think it's needed). My server is pingale with the .local suffix, but alas, nothing at pi.hole.

Very frustrating when I want to modify the web UI (though I can obviously still use the IP).

Are you sure that device is actually using Pi-hole and can reach it via IP address? You might have multiple DNS servers in use.

Of course. I can reach it by IP, and it is using the pi-hole as a DNS server. It just doesn't consistently reach pi.hole (as opposed to the IP).

Check that Pi-hole is the only DNS server. Having inconsistent access to pi.hole is indicative of having multiple DNS servers in use.

1 Like

It absolutely is. My devices (Ubuntu, OS X and Android respectively) all receive the pi.hole as the sole DNS provider from my Ubiquiti USG.

In some cases, intermittent performance problems are indicative of a hardware problem. What power supply are you using for your Pi, what card brand, and how do you have the Pi connected to the network?

What is the output of nslookup pi.hole?

If that were the case I'd see other issues. Ad-blocking works perfectly, and I'm seeing no network issues (drops, ping/traceroute tests, etc)
The thing is, it's resolving now, so nslookup is resolving as it should. Other times it does not resolve (but everything else works properly).

:zap: nslookup pi.hole



Non-authoritative answer:

Name: pi.hole


Name: pi.hole

Address: fe80::a565:22f0:3710:1c06

And google:

:zap: nslookup google.com



Non-authoritative answer:

Name: google.com


Name: google.com

Address: 2607:f8b0:4006:80f::200e

The server address is listed as localhost, but that's because of Ubuntu's systemd.

When it's not resolving correctly, share the nslookup output (and dig pi.hole if that's available).

@op - How is your router configured to use pi-hole's IP as the DNS? See: Pi-hole and ddwrt settings - #6 by graysky2

It uses for itself, and hands out the pihole ip for DNS through DHCP.

That said, I think I fixed it. In my previous configuration, I had the router handing out the pihole as the primary DNS, and then (without much thought) I had set the secondary and tertiary DNS servers as and

A few days ago, I realized this was superfluous, and removed them, leaving only the primary. Since then I have had no problems with local hostname resolution, and my mobile ads were more consistently being blocked! It likely affected my Linux machines as well, but I wouldn't have noticed because they have adblockers. It's strange, though - pihole was definitely blocking (I had to frequently whitelist domains for my wife's work) before these changes.

So I think I'm ok now - thanks for your help, everyone! And Graysky, see you in Archland.

The right way to do it is to put your entries into /etc/hosts and in the pihole admin interface Settings > DNS tab uncheck the "Never forward non-FQDNs" and the "Never forward reverse lookups for private IP ranges" checkboxes. After that on the System tab restart the DNS resolver.


You can also map them in a dnsmasq configuration file in directory /etc/dnsmasq.d The advantage of mapping here is that this configuration file will be exported by the teleporter, while the /etc/hosts file will not be. This is true for V4.x; in V5 the hosts file will be exported.

Hi, I am finding this a little confusing as I am using Pi-hole as an add-in to Home Assistant.

I find the suggestion to remove the secondary dns server from the dns section in the router also works for me. The primary dns server is the local address of the rpi4 that is running hassio, which has pi-hole set up as an add-in.

I am a little worried not having a secondary dns server set up as the rpi4 may be offline from time to time.....

I have tried the pihole admin interface settings and turned the unchecked both these boxes but have not put my entries into /etc/hosts.

I do not know exactly where this /etc/hosts file will be located. My understanding is that the hass io system has pihole running in a docker and I cannot see any volumes mounted. I will probably need to ask the hass io people about gaining access to the /etc/hosts file, but need to know what to ask for.

Thanks in advance.

I believe that I have the most updated version of Pi-Hole on Raspberry Pi (I just installed it a couple of days ago).

/etc/dnsmasq.d says that it is a directory, but I was able to edit /etc/dnsmasq.config with the following and it worked: address=/RaspberryPi/

I also read https://www.reddit.com/r/pihole/comments/6eeo6z/static_dns_entries/ that I could use code in the dnsmasq.config file this to re-direct all local queries? but this didn't seem to work:

I also tried to use the web portal and setup Conditional Formatting. (using the IP of my router that does DHCP and the domain name of Local) Note, my Router is ISP provided so I'm not 100% about using local as the domain, the LAN doesn't say anything about a domain, the WAN says 'telus' but I'm not sure that's what I should be using? Anyways, considering that Conditional Formatting is built into the system, wouldn't this be the best way to do this?

However that seems to overload (Spam) my system with SOA requests.