Warning in dnsmasq core: using interface eth0 instead (Pi-Hole running on virtual interface eth0:0)

Expected Behaviour:

I´m running Pi-Hole on a virtual interface eth0:0. I updated to latest versions (core 5.7, web 5.9, ftl 5.12.1). When Pi-Hole starts up, the web interface is clear. No warnings.

Actual Behaviour:

After every Pi-Hole start, a warning is shown in the web UI:

Debug Token:


Additional information:

The warnings have always existed in /var/log/pihole.log. A change to Pi-hole made them more visible by also printing them into /var/log/pihole-FTL.log and showing them on the dashboard.

The warning you encountered is about a shortcoming of dnsmasq which doesn't fully support alias interface. When you set it to listen on eth0:0 it indeed listens on eth0 instead. This causes the warning you'rev seeing. Your Pi-hole works as you expect it to as it catches the packets on the alias interface because this is still the same physical device.

I prepared a Bugfix for this and gave some more technical details here:

You could try true binding to the alias interface instead, there is a fourth interface listening option for this in the most recent Pi-hole release

1 Like

Okay got it. Still not sure what to think about those messages put in front so prominent - makes me personally feel a bit uncomfortable tbh. Maybe I just need to get used to this UI change and learn to safely ignore those warnings… which also is not a good behavior I think :slight_smile:

Meanwhile there are even more warnings I need to (should I?) take a look at.

Anyway: what is that 4th option -> it is the bind option one below the current respond one I guess. Doesn‘t sound like something I‘m looking for according to the docs https://docs.pi-hole.net/ftldns/interfaces/:

About the only time when this is useful is when running another nameserver on the same port on the same machine. This may also happen if you run a virtualization API such as libvirt.

Man DNS has become quite complicated. Props to all you guys mastering all that technical details :wink: :+1:

For now I think I‘ll start living with and probably ignoring those warnings. As you said - they‘ve always been there and things are working fine anyway.

Thanks for explanations - and merry x-mas :slight_smile:

No, you can change your configuration to avoid them.

The warning using interface eth0 instead should be resolved in the future when my patch (see PR above) is submitted and accepted in dnsmasq upstream. As said, the warning is just there to notify you that dnsmasq may be behaving differently than you configured it to. If this different behavior is okay for you, that's okay.

The other warning, reducing DNS packet size can be avoided by


as described on the warnings docs page: https://docs.pi-hole.net/ftldns/dnsmasq_warn/


1 Like

So I need to create the separate file as stated on the page or can I add it to the /etc/pihole/pihole-FTL.conf?

It needs to go into a separate file in /etc/dnsmasq.d/

1 Like

A post was merged into an existing topic: DNSMASQ_WARN reducing DNS packet size

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.