Update schlägt fehl


#1

Hallo,
Bei mir klappt seit Tagen das Update auf die neuste Version nicht. Wenn ich pihole-up eingebe bekomme ich folgende Fehler angezeigt

[i] Checking for updates…
fatal: unable to access ‘https://github.com/pi-hole/pi-hole.git/’: Failed to connect to github.com port 443: Connection refused
[i] Pi-hole Core: up to date
fatal: unable to access ‘https://github.com/pi-hole/AdminLTE.git/’: Failed to connect to github.com port 443: Connection refused
[i] Web Interface: up to date
[i] FTL: update available

[i] FTL out of date, it will be updated by the installer.

Und weiter unten…

[✓] Detected ARM-hf architecture (armv7+)
[i] Checking for existing FTL binary…
[✗] Downloading and Installing FTL
Error: Unable to get latest release location from GitHub
[✗] FTL Engine not installed
[✓] man pages installed and database updated
[i] Testing if systemd-resolved is enabled
[i] Systemd-resolved is not enabled
[✓] Starting lighttpd service…
[✓] Enabling lighttpd service to start on reboot…
[i] Restarting services…
[✓] Enabling pihole-FTL service to start on reboot…
[✓] Starting pihole-FTL service…
[✓] Deleting existing list cache
[i] Pi-hole blocking is enabled
[✗] DNS resolution is currently unavailable
[✓] DNS resolution is now available

Kann mir jemand sagen was hier warum falsch läuft?
Vielen Dank im voraus.


#2

Hi,

auf einem Rechner, welcher den Pi mit Pi-hole als DNS Server verwendet, kannst du darauf die beiden URLs

https://github.com/pi-hole/pi-hole.git
https://github.com/pi-hole/AdminLTE.git

erfolgreich im Browser öffnen?


#3

Nein, die Seiten gehen nicht auf. Habe zwei Geräte getestet. Im mobilfunknetz gehen sie auf.
Hab pi hole mal zum Spaß deaktiviert, auch dann gehen die Seiten nicht auf.


#4

Füge github.com zur Whitelist hinzu. Ich würde zudem vorschlagen diese Domain dort dauerhaft zu belassen.

Es kann sein, dass es danach einige Zeit dauert, bis der Client (Rechner) die IP für Github erneut beim DNS Server (Pi-hole) abfragt.


#5

So, nach viel hin und her habe ich das Update bekommen. Lag aber nicht am pi hole. Auch ohne Eintrag in die whitelist geht es nun. Ein Neustart der fritzbox hat Abhilfe geschaffen.
Keine Ahnung was da los war.
Danke für die Hilfe.