Unifi Network Pi-hole configuration

Another test. I created a wifi network for the native LAN. I get the same result as all VLAN when trying nslookup pi.hole. no blocking for flurry.com

While connected to a configured wireless network that points to the Pi-Hole, if I set the DNS server on my laptop directly, everything works. If I revert back to (USG) it doesn't work again.

Anybody have any thoughts? UI support couldn't help me.

Have you tried keeping the USG as the DNS server for your clients, and then pointing the USG itself at the pihole? I use Google WiFi (Not a USG), and I had to set mine up this way for it to work properly.

One other thing that might be causing issue is domain auto completion. I had an issue with my mac refusing to look up pi.hole without appending a ".lan" on the end (pi.hole.lan) So I added a new local DNS entry called "pihole.dmz." This is the name that I use for my pihole now. I also added "DMZ" to auto completion. You may have to play around with auto completion and local DNS for it to work properly for you.

The name change also fix another issue for me, my pihole's address is not accessible to my clients due to a NAT. "pi.hole" resolves to the not accessible address. "pihole.dmz" resolves to the correct NAT address.

I have no idea what you are doing but you are doing it wrong! :stuck_out_tongue:

Just do the following :

  • Setup a VLAN Interface for each VLAN you are using.
  • Add the IP of that VLAN Interface to the DHCP DNS Settings for each VLAN in the UniFi Controller.
  • Make sure you have a additional config file for Pi-Hole which states that it should use those VLAN Interfaces!

This is the config on a Raspberry Pi running RaspBian :
apt install vlan
echo "8021q" >> /etc/modules
modprobe 8021q

/etc/dhcpcd.conf :
#eth0 VLAN 10 DNS IP :
interface eth0.10
static ip_address=

A file called vlans in the directory /etc/network/interfaces.d :
auto eth0.10
iface eth0.10 inet manual
vlan-raw-device eth0

Make sure Pi-Hole knows what to do by creating a file called 101-my.settings inside /etc/dnsmasq.d/ :

And then to finish it all :
systemctl restart networking
pihole restartdns

Aaaand you are done! :wink:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.