Unbound!

Those of you who live in Apple eco-system :wink: … and using Unbound, did you have issues such as:

  • Not able to access / download purchased apps / games from App Store (macOS Catalina)?
  • Problem access / log in App Store / iTunes with Apple Watch?
  • Etc?!!

It took me over 4 months, numerous install / reinstall of macOS / iOS / WatchOS, Raspberry Pi & Pi-hole etc, deleting over 3,000,000 in my block lists including the default list - no luck.

As a result and as of this morning, I officially gave up on Unbound and switched to Cloudflared (DOH) with the same 3,000,000 block list no problem! In fact, I can use any other DNS provider as well!

Any comment?

Edit: Forgot to mention the error!! Pic attached.

I use Unbound works fine on my iPads, iTune Store / App store works.

None of the above. Have never had a problem with any of the Apple services while running unbound - Apple Store, iTunes, updates, iCloud, etc. all work fine.

Did you compare the IP address returned from unbound with the IP address returned from other DNS resolvers?

I did not think of comparing the IP address returned from Unbound. However, I checked the servers’ names my devices were communicating - they were consistent with or without Unbound.

Main reason it took me so long to pinpoint the cause was reported issues like this which made me believe it was Apple’s problem / screw up:

So, I wasted so much time with Apple support as well as my own environment and even my ISP!

My ISP still doesn’t support IPv6 but 6to4. At one point, I thought that could be the issue - it was not!

As mentioned, after all steps, I focused on my 2 Raspberry Pi configured as primary and secondary and Unbound and etc!

Here’s more details about my problems with App Store …

For example, I can log in to App Store (macOS Catalina). There, I can see what apps I purchased but when I click on its little cloud icon to download the app/s, I was getting that error! I had to log out / in a number of times to get them!

There, I was able to log in to iTunes (now called Music) and go to my account detail. When I click on purchased history and then click on “back” arrow to get back to my account, it was popping up the message that iTunes Store is unable to process purchases at this time … blah blah!!

I did NOT want to purchase anything!!

No problem on my iPhone or iPad Pro downloading apps!

However, my Apple Watch was showing that error when syncing apps from my iPhone!! My workaround was like power cycling my iPhone and Apple Watch a few times! Then, I learned if I disconnect my iPhone from WiFi, then it would sync apps to Apple Watch!

Anyway, what a mess and stressful time!

I need to give myself break for a few months and then try Unbound again! Hopefully, it’ll get resolved - somehow!

Thank you all for your time.

1 Like

I experienced something similar with my watch where it would give me a hard time syncing apps while on (home) WiFi.

I’ll definitely keep this in mind if (and when) it happens …

Didn’t think for a second to take it off WiFi …

@RamSet, I turned off WiFi on my iPhone because of so much anger and desperation not knowing what the heck was going on - and to my surprise it worked every single time!

So, that was another reason to suspect my own environment and not blaming Apple!!

Although, I still see the same problems even when I use any DNS values directly in my router (AmpliFi HD Gamer’s Edition!) but they go away after couple of retries. With Unbound, I was 100% stuck!

1 Like

I ended up replacing the watch :smiley: (it did feel like it had different issues too).

I hear ya - Apple quality has gone down the hill both in software and hardware department!!

Just to test things further, I’ve been trying Cloudflare DOH but still seeing similar symptoms - manageable though and not as bad - meaning, click / tab on retry a few times and I’m in!!

FWIW, I asked a few friends to try with their own ID - NO PROBLEM for them in my place or even when using my own MacBook / iPhone / iPad! It’s just me when I use my own Apple ID!!

Hardly I call for tech support but I decided to spend a few very long hours with Apple support and also with their senior advisors = no luck! They didn’t even know what Pi-hole or Unbound are in first place!!

Waste of my precious time instead wrestling with my 2 precious dogos!!