Unable to update my pihole on Debian 11 : "Error: Web Admin repo is missing from system!"

Hello everyone,

i'm having trouble updating my pihole on debian 11.

Expected Behaviour:

when trying to sudo pihole -up, i got this message in return :

Error: Web Admin repo is missing from system!

then I'm trying a sudo pihole -r, but again another error :

Unable to reset /var/www/html/admin, exiting installer

  • Debian 11
  • Lighttpd

I need to update Pihole to get back the OISD list to work.

Thanks for your help :slight_smile:

Debug Token:


duplicate? see here, with solution...

Thanks for your answer.

My pihole folder is not in


but in


will it be ok anyway ?


EDIT : tried the solution in the other post but still the exact same error about the web repo missing...

Why? Is this because of your unsupported configuration?

[✗] tcp:*:80 is in use by apache2 (https://docs.pi-hole.net/main/prerequisites/#ports)

I use apache2 for other services on my server and Apache is taking port 80.

I've choosen the port 8080 for lighttpd then.

Is this not recommanded ?

I've read your link and i've seen that part :
You can either disable the other Web server or change the port on which lighttpd listens, which allows you keep both Web servers running.

So this is what i've done so far, change the port of lighttpd.
It doesn't look like it is an unsupported configuration ?

You can change the port, but we recommend to do this using a separate config file.

Changes made to /etc/lighttpd/lighttpd.conf file might be overwritten on the next update.
To avoid this, add a new file (Example: /etc/lighttpd/conf-enabled/15-pihole-port.conf) with this code:

server.port := 8080

Use the := operator.

I've added that file then restart the lighttpd service but still have the error about web repo missing.

Sorry. Reading your previous post I thought you already had that fixed and the question was only about the lighttpd config.

Why did you changed the directory from /var/www/html/ to /var/www/?
Pi-hole installer expects the web interface on this path.

because i've also Apache running on the server and this folder already contains the apache default page. Does it matter if i use the same folder ?

It will be a problem only if the current folder already has a directory named /admin.

But your debug log shows this directory doesn't exist:

*** [ DIAGNOSING ]: Web version
Directory /var/www/html/admin doesn't exist

Thanks, i could update the pihole.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.