Unable to update FTL on Ubuntu, also unable to repair


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

I want to update to the latest version of FTL. I run
sudo apt-get update
pihole -up

Actual Behaviour:

sudo apt-get update works fine

pihole -up shows this in at the start: fatal: unable to access ‘https://github.com/pi-hole/pi-hole.git/’: Failed to connect to github.com port 443: Connection refused

I have tried pihole -r, that gets to the loading bar then tells me the update will close.

I have had FTL update errors in the past, I have added “nameserver 1.1.1.1” to /etc/resolv.conf and nothing changed.

I have restarted the service for no change.

Debug Token:

https://tricorder.pi-hole.net/vplbfq3qho!


#2

It looks like you can resolve github.com to a proper IP address so the Pi-hole DNS is working. Getting a connection refused is typically a firewall or content blocker issue.

What does curl -IL https://github.com/pi-hole/pi-hole.git show?


#3

It shows curl: (7) Failed to connect to github.com port 443: Connection refused


#4

Something is blocking you from accessing GitHub.

What does dig github.com show?


#5

dig github.com

; <<>> DiG 9.11.3-1ubuntu1.5-Ubuntu <<>> github.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42455
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;github.com.                    IN      A

;; ANSWER SECTION:
github.com.             2       IN      A       0.0.0.0

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Mar 15 12:32:12 AWST 2019
;; MSG SIZE  rcvd: 55

#6

You’re blocking GitHub.


#7

Ok, I have no idea how. Ubuntu is running on a VM, and the firewall doesn’t block github as far as I know. I’ll investigate.

Thanks.


#8

It looks like Pi-Hole is blocking github. This command will show which blocklist is the offender:

pihole -q -adlist github.com

To unblock it, add it to the white list.


#10

Thanks, I added it to the whitelist but still can’t update. The error message about github is gone, but the update stops at

Checking for php7.2-sqlite3

When I run

pihole -r

I get the same result


#11

Resolved. This VM also hosts a unifi controller that apparently had a broken upgrade that was blocking all updates. I ran

sudo apt-get upgrade -y

and then

pihole -up

worked flawlessly