Ubuntu 18.04 - FTL Offline and Spinning wheel on Dashboard


#1

Please follow the below template, it will help us to help you!

Expected Behavior:

FTL Online, Dashboard working

Actual Behavior:

FTL Offline; Dashboard has spinning wheels

Debug Token:

e498qct85w


#2

Do you see any errors in /var/log/pihole-FTL.log or journalctl -u pihole-FTL?


#3

I see no errors during the setup, running the pihole -r; I’ve followed all of the suggestions on these forums and I get nothing. Thoughts?


#4

Please upload a new debug log and post the token. The first one has expired.


#5

I will do that when I get home tonight. Will send another e-mail that the token has been posted.

Thank you. Regards


#6

No need for the email. Post the token in this thread and we’ll get notified of the new post.


#7

New Debug token: d4z3e778ph


#8

Is this a new install? Has the Pi-Hole ever worked properly, or is this a new problem?

What are the outputs of the following commands from the Pi-Hole host terminal?

sudo service pihole-FTL status

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'


#9

This is a new install, freshly upgraded to 18.04; never installed pi-hole previously. Output:

● pihole-FTL.service - LSB: pihole-FTL daemon
   Loaded: loaded (/etc/init.d/pihole-FTL; generated)
   Active: active (exited) since Sat 2019-01-05 15:11:44 EST; 3 days ago
     Docs: man:systemd-sysv-generator(8)
  Process: 23748 ExecStop=/etc/init.d/pihole-FTL stop (code=exited, status=0/SUC
  Process: 23765 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/S
Jan 05 15:11:44 familyPlex systemd[1]: Starting LSB: pihole-FTL daemon...
Jan 05 15:11:44 familyPlex pihole-FTL[23765]: Not running
Jan 05 15:11:44 familyPlex su[23817]: Successful su for pihole by root
Jan 05 15:11:44 familyPlex su[23817]: + ??? root:pihole
Jan 05 15:11:44 familyPlex su[23817]: pam_unix(su:session): session opened for u
Jan 05 15:11:44 familyPlex pihole-FTL[23765]: dnsmasq: failed to create listenin
Jan 05 15:11:44 familyPlex su[23817]: pam_unix(su:session): session closed for u
Jan 05 15:11:44 familyPlex systemd[1]: Started LSB: pihole-FTL daemon.

and

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 [0.0.0.0:80](http://0.0.0.0:80)              0.0.0.0:*               LISTEN      23459/lighttpd
tcp        0      0 [169.254.13.47:53](http://169.254.13.47:53)        0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.26.181:53](http://169.254.26.181:53)       0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.169.146:53](http://169.254.169.146:53)      0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.112.19:53](http://169.254.112.19:53)       0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.98.169:53](http://169.254.98.169:53)       0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.38.60:53](http://169.254.38.60:53)        0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.9.157:53](http://169.254.9.157:53)        0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [169.254.165.5:53](http://169.254.165.5:53)        0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [172.17.0.1:53](http://172.17.0.1:53)           0.0.0.0:*               LISTEN  	2220/named
tcp        0      0 [192.168.1.172:53](http://192.168.1.172:53)        0.0.0.0:*               LISTEN      2220/named
tcp        0      0 [127.0.0.1:53](http://127.0.0.1:53)            0.0.0.0:*               LISTEN      2220/named
tcp6       0      0 :::80                   :::*                    LISTEN      23459/lighttpd
tcp6       0      0 :::53                   :::*                    LISTEN      2220/named
udp        0      0 [169.254.13.47:53](http://169.254.13.47:53)        0.0.0.0:*                           2220/named
udp        0      0 [169.254.26.181:53](http://169.254.26.181:53)       0.0.0.0:*                           2220/named
udp        0      0 [169.254.169.146:53](http://169.254.169.146:53)      0.0.0.0:*                           2220/named
udp        0      0 [169.254.112.19:53](http://169.254.112.19:53)       0.0.0.0:*                           2220/named
udp        0      0 [169.254.98.169:53](http://169.254.98.169:53)       0.0.0.0:*                           2220/named
udp        0      0 [169.254.38.60:53](http://169.254.38.60:53)        0.0.0.0:*                           2220/named
udp        0      0 [169.254.9.157:53](http://169.254.9.157:53)        0.0.0.0:*                           2220/named
udp        0      0 [169.254.165.5:53](http://169.254.165.5:53)        0.0.0.0:*                           2220/named
udp        0      0 [172.17.0.1:53](http://172.17.0.1:53)           0.0.0.0:*                           2220/named
udp        0      0 [192.168.1.172:53](http://192.168.1.172:53)        0.0.0.0:*                           2220/named
udp        0      0 [127.0.0.1:53](http://127.0.0.1:53)            0.0.0.0:*                           2220/named
udp6       0      0 :::53                   :::*                                2220/named

#10

Process “named”, which is typically bind9, is running on port 53. Verify with

sudo lsof -i :53

This process must be stopped and disabled, then pihole-FTL started.

If BIND9 is the process, then these commands should do it:

sudo service bind9 stop

sudo systemctl disable bind9

sudo service pihole-FTL start


#11

interesting - dashboard now works, clients are passing through; but it shows Red lights for DNS service not running and FTL offline still. I did a full restart of the server.


#12

What are the outputs now:

sudo lsof -i :53

sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'

Edit - and please post a new debug token.


#13


[✓] Your debug token is: pmb3856xin



COMMAND    PID   USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
pihole-FT 5970 pihole    4u  IPv4  47018      0t0  UDP familyPlex:domain
pihole-FT 5970 pihole    5u  IPv4  47019      0t0  TCP familyPlex:domain (LISTEN)
pihole-FT 5970 pihole    6u  IPv4  47020      0t0  UDP localhost:domain
pihole-FT 5970 pihole    7u  IPv4  47021      0t0  TCP localhost:domain (LISTEN)
pihole-FT 5970 pihole    8u  IPv6  47022      0t0  UDP familyPlex:domain
pihole-FT 5970 pihole    9u  IPv6  47023      0t0  TCP familyPlex:domain (LISTEN)
pihole-FT 5970 pihole   10u  IPv6  47024      0t0  UDP ip6-localhost:domain
pihole-FT 5970 pihole   11u  IPv6  47025      0t0  TCP ip6-localhost:domain (LISTEN)

 sudo netstat -nltup | grep 'Proto\|:53 \|:67 \|:80 \|:471'
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2309/lighttpd
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      5970/pihole-FTL
tcp        0      0 192.168.1.172:53        0.0.0.0:*               LISTEN      5970/pihole-FTL
tcp        0      0 127.0.0.1:4711          0.0.0.0:*               LISTEN      5970/pihole-FTL
tcp6       0      0 :::80                   :::*                    LISTEN      2309/lighttpd
tcp6       0      0 ::1:53                  :::*                    LISTEN      5970/pihole-FTL
tcp6       0      0 fe80::6e0b:84ff:fede:53 :::*                    LISTEN      5970/pihole-FTL
tcp6       0      0 ::1:4711                :::*                    LISTEN      5970/pihole-FTL
udp        0      0 127.0.0.1:53            0.0.0.0:*                           5970/pihole-FTL
udp        0      0 192.168.1.172:53        0.0.0.0:*                           5970/pihole-FTL
udp6       0      0 ::1:53                  :::*                                5970/pihole-FTL
udp6       0      0 fe80::6e0b:84ff:fede:53 :::*                                5970/pihole-FTL

#14

And now, without any other actions taken since the last debug run, everything is working!


#15

Glad it’s working again. The log output shows that named is no longer running, and pihole-FTL is.

The problem with the web admin GUI showing the new status may have been the browser cache showing the old data.


#16

Great - thank you.