Top Clients (total) and Top Clients (blocked Only) only showing IP addresses after latest Update

The issue I am facing:
Since updating to versions, PiHole 5.5, FTL 5.10.1. and Web interface 5.7, both the top clients (total) and Top clients (blocked Only) are now only showing the IP address of each client via the web gui.

I have checked the DHCP setting for Pihole and it is enabled. The client host names still exists in the Local DNS records and the custom list in etc/pihole/ is also still good and correct.

The Query log also only shows an IP address within the client column as well.

I have tried delting an existing entry in the Local DNS via the GUI and then recreating it still the same issue, i.e. only yhe IP address is diaplaying in the web GUI..

Is tthis a bug from the latest version or has something changed?

What I have changed since installing Pi-hole:
Nothing

Please upload a debug log and post just the token that is generated after the log is uploaded by running the following command from the Pi-hole host terminal:

pihole -d

or do it through the Web interface:

Tools > Generate Debug Log

Here is the link the debug log:

https://tricorder.pi-hole.net/MASKXsei/

Any update on this issue?

Nothing jumps out in the debug log as a problem. Please post some screen shots of what you see. In this forum, you can paste images directly into your reply.

Edit - it's not clear why you see a web admin GUI since this appears to be disabled in your debug log.

Not sure either, but the web gui is working, from where should it be enabled?


First image from the query log, second from the Local DNS record

I can see in the debug log that DHCP is picking up the correct host name, but the GUI continues to display only yhe IP address and not the host name.

Any idea when this problem is going to be fixed and or how to fix it? Something has definitely changed in this current version, which has broken the host name assignment to IP addresses from local dns records at least from the GUI front end.

So I assume there is no solution for this problem, with the current version of pihole?

It sounds to me that this may be related to the recent changes where pihole short lives cache data of hostnames.

  • Handle TTL for blocked queries separately
    You can now set your own local-ttl value if you want to.
    Note that this changes the default TTL for local hostnames from two seconds to “do not cache” ( dnsmas q’s default). If you want to avoid this, create a file like /etc/dnsmasq.d/99-local-ttl.conf and add a line like local-ttl=60 for one minute TTL on local hostnames.

Thanks for your reply, I took your suggestion and applied it. This is what I see:

image
The only entry inside the 99-local-ttl.comf, is local-ttl=60

The same problem exists though

Did you go through restarting the PiHole server after making the changes?

Was hoping I may get some sort of acknowledgement from the pihole team of this bug. But they are being pretty quiet over this issue.

I did indeed made no difference.

Upload a new debug log please.

Here you go:

https://tricorder.pi-hole.net/vpcSAilH/

*** [ DIAGNOSING ]: contents of /etc/lighttpd

-rw-r--r-- 1 root root 2.1K Jun 19  2020 /etc/lighttpd/lighttpd.conf

That's not our lighttpd.conf file. You're not running what we use for the web interface.

$ cat /etc/lighttpd/lighttpd.conf
# Pi-hole: A black hole for Internet advertisements
# (c) 2017 Pi-hole, LLC (https://pi-hole.net)
# Network-wide ad blocking via your own hardware.
#
# Lighttpd config for Pi-hole
#
# This file is copyright under the latest version of the EUPL.
# Please see LICENSE file for your rights under this license.

###############################################################################
#     FILE AUTOMATICALLY OVERWRITTEN BY PI-HOLE INSTALL/UPDATE PROCEDURE.     #
# ANY CHANGES MADE TO THIS FILE AFTER INSTALL WILL BE LOST ON THE NEXT UPDATE #
#                                                                             #
#              CHANGES SHOULD BE MADE IN A SEPARATE CONFIG FILE:              #
#                         /etc/lighttpd/external.conf                         #
###############################################################################

server.modules = (
    "mod_access",
    "mod_accesslog",
    "mod_auth",
    "mod_expire",
    "mod_redirect",
    "mod_setenv",
    "mod_rewrite"
)

server.document-root        = "/var/www/html"
server.error-handler-404    = "/pihole/index.php"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"
server.pid-file             = "/run/lighttpd.pid"
server.username             = "www-data"
server.groupname            = "www-data"
server.port                 = 80
accesslog.filename          = "/var/log/lighttpd/access.log"
accesslog.format            = "%{%s}t|%V|%r|%s|%b"

index-file.names            = ( "index.php", "index.html", "index.lighttpd.html" )
url.access-deny             = ( "~", ".inc", ".md", ".yml", ".ini" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

mimetype.assign = (
    ".ico"   => "image/x-icon",
    ".jpeg"  => "image/jpeg",
    ".jpg"   => "image/jpeg",
    ".png"   => "image/png",
    ".svg"   => "image/svg+xml",
    ".css"   => "text/css; charset=utf-8",
    ".html"  => "text/html; charset=utf-8",
    ".js"    => "text/javascript; charset=utf-8",
    ".json"  => "application/json; charset=utf-8",
    ".map"   => "application/json; charset=utf-8",
    ".txt"   => "text/plain; charset=utf-8",
    ".eot"   => "application/vnd.ms-fontobject",
    ".otf"   => "font/otf",
    ".ttc"   => "font/collection",
    ".ttf"   => "font/ttf",
    ".woff"  => "font/woff",
    ".woff2" => "font/woff2"
)

# Add user chosen options held in external file
# This uses include_shell instead of an include wildcard for compatibility
include_shell "cat external.conf 2>/dev/null"

# default listening port for IPv6 falls back to the IPv4 port

# Prevent Lighttpd from enabling Let's Encrypt SSL for every blocked domain
#include_shell "/usr/share/lighttpd/include-conf-enabled.pl"
include_shell "find /etc/lighttpd/conf-enabled -name '*.conf' -a ! -name 'letsencrypt.conf' -printf 'include \"%p\"\n' 2>/dev/null"

# If the URL starts with /admin, it is the Web interface
$HTTP["url"] =~ "^/admin/" {
    # Create a response header for debugging using curl -I
    setenv.add-response-header = (
        "X-Pi-hole" => "The Pi-hole Web interface is working!",
        "X-Frame-Options" => "DENY"
    )
}

# Block . files from being served, such as .git, .github, .gitignore
$HTTP["url"] =~ "^/admin/\.(.*)" {
    url.access-deny = ("")
}

# Default expire header
expire.url = ( "" => "access plus 0 seconds" )