Table won't load after update

Same here. Chrome JavaScript console output:

I also ran the debug:
Your debug token is : q4zs727xuk

It appears that you haven't set any upstream DNS servers:


What DNS server did you choose during setup?

Your error is related to caching. We have updated all libraries. The error shows the old ones. Please clear your cache.

1 Like

That did it. Thank you!

I'm using DNScrypt from [OUTDATED] Setting Up and Using DNScrypt-Loader

Ok, can you set the DNS servers in /etc/pihole/setupVars.conf to the ones you set in that guide?

I did this and I still encountered errors, however I noticed the issue was with the adlist itself. If I tried to view the query log with pihole -g running, it would load fine, but when it was complete, it would throw the error. I backed up my adlist and restored it with the default one and now everything works. The issue is something within the adlist.

Make sure it is in a HOST format, either:
where can be any address.

I tailed the log and found the issues from the following adlists:

# Untested lists

# Custom

Removed them and the log works fine. Thanks!

Where do I make those changes? I'm having the same issue and I'm not quite savvy enough to know exactly where that is.


sudo nano /etc/pihole/adlist.list

1 Like

Yeah, that file is showing empty.

Sorry, it's:

sudo nano /etc/pihole/adlists.list

that silly hidden 's'...

So, I '#' the two custom 'emd.txt' and 'exp.txt' and I'm still getting the same ajax error.

Here's what I did, I ran sudo pihole -t in terminal and updated the adlist from the admin panel. Once gravity finished updating, I watched for errors.

I went into /etc/pihole/gravity.list and located the troublesome domains. I used the feature in the admin panel to pinpoint what list was giving me issues. This fixed it for me.

Weirdly enough, I just tried to re-add the troublesome adlists and the log didn't break. Not quite sure why, maybe a dev could chime in.

Interesting... and thanks for the help

I tried to replicate what you are doing and when I run pihole -t, basically, it runs forever. I tried to run the update list on the web admin and nothing worked. So, I can't duplicate what you are trying, but I'm also trying that on the Pi's browser, so I'm going to try to duplicate it when I head home shortly.

Ran it now that I'm home and I didn't get any errors like you are showing on yours. But I'm still getting the same error. I have also submitted my token to one of the developers on Reddit as well...

Hmmm... gonna continue to dig around!

Look at this post for your particular error.

Thanks Mcat12, I flushed the log files and I'll wait to see if I have the same issue tomorrow, after midnight. Or should this resolve the issue "permanently"?