Synology wants me to log in?


#1

Got pihole installed on my synology 214+ last night and after some fiddeling with my router i got it working fine.
and the restart script was also installed correct so all is good.

My Synology is set to restart once in the middle of the night just to keep it in ship shape.
When i got my ipad this morning and went on the internet and instead of my normal newspaper site i was greeted by the Synology Diskstation Login page. And I could not get to any site before i logged in. Very weird.

My NAS is setup with ip 192.168.1.125 port 1080
and my Netgear router is set up with ip 192.168.1.2 and it uses 192.168.1.125 as Primary DNS (nothing as secondary DNS)
The ipad Gateway and DNS is is set to 192.168.1.2.

Any idea why i got the diskstation login screen, is this normal procedure that I have to login after a restart of the NAS - that could get quite annoying for the wife and kids.


#2

Got home from work
Now my android phone wants me to login to connect to my wifias in a school or an airport. but i get no login page or anything.
so i have to disable the pihole DNS on my router. this is really wierd.

During installation of PI hole on the synology i typed in the pihole ip adress as 192.168.1.125 - same as the synology, was this wrong?


#3

Are you using the Docker image? It should not show a login screen. Try changing the port of the Synology dashboard.


#4

No docker image, installed per the instructions on this forum.
tried changing the port of the diskstation but it is still the same. When i go to a site like google.com my ipad loads the diskstation login page and the address bar shows google.com:5000.
so something is not right.


#5

Removed pihole from my synology and installed it on an old Pi1 i had lying around som no trouble now :slight_smile: