Swapped to new router, please help


Please follow the below template, it will help us to help you!

Expected Behaviour:

I swapped the router from an ASUS to a Linksys router, I would like to get the pi-hole running.

Actual Behaviour:

I am not sure how to disable router DCHP or how to get the pi hole running again with the new router, it is Linksys AC3200 WRT32X.

Debug Token:




Your debug log shows that your Pi-Hole is running normally, at IP



In this image, I have tried method three (I didn’t do this first)
I did this first, I changed the DNS to the pi-hole.

This is the result in both cases.



You are most likely using an IPV6 DNS resolver (IPV6 takes priority over IPV4 when both are set-up).

You can either disable IPV6 in/on your network/client, OR, make sure that your router is broadcasting/using yout IPV6 IP of your Pi-hole as the IPV6 DNS (or manually set it up under your client IPV6 settings).

You can actually see what DNS your requests are going through by visiting https://www.dnsleaktest.com/



I am back at work right now, I used team viewer. the website results is it is not the pi hole.

I don’t know if there is a way to disable IPV6 on the router. The model is Linksys AC3200 WRT32X.

For the 2nd option, do I need to check Enable IPv6 support (SLAAC + RA) under the DHCP setting son the pi-hole?



That should be the public facing IP of the Pi-hole device


Here you go.

Yes, that, HOWEVER, you need to make sure that the IPV6 stays the same on the Pi-hole device and does not change (compared to IPV4, IPV6 behaves differently). You can kind-of achieve that with several network related changes on the Pi-hole device OR simply disable IPV6 within the network properties for that adapter under windows …

If IPV6 is desidred, you can then specify the IPV6 DNS under the adapter on your client but you MUST set it up as your IPV6 DNS on your router too.

Give it a spin, see where it lands you like that.

If you really need IPV6 within your network, you’ll have to take the long route of establishing stable IPV6 ip addressee on the Pi-hole device.

I, personally have IPV6 disabled …



This link doesn’t help me in my situation, unless I am not looking at the right places:

Here is a screen shot of the UI of the router:

Blockquote disable IPV6 within the network properties for that adapter under windows
I have tried this:
Capture_2019_03_22_17_35_33_19 Capture_2019_03_22_17_35_21_255

The IPV6 is already turned off on the router:

I have set my pi-hole as my DNS server:



This is likely not your problem, but I thought I should throw it out there. Does your new router hand out the same IPs as your old one? For example your old router may have handed out 192.168.1.x while your new router hands out 192.168.0.x. You likely set a static IP on your Raspberry Pi when setting up Pi-Hole using your old router, and switching to the new one could have caused some issues if it doesn’t use the same IP.



Does your new router hand out the same IPs as your old one?


I also had to set static ip on most devices on my network. Lucky some devices had no problem connecting to the network, that is including the pi-hole.

I had a ASUS router that stopped working for some reason. I was able to get the pi hole to work by running it as the DHCP server. With this router I have right now, which is a Linksys AC3200 WRT32X, I want to run it by this forum if I could do the same. In the old router, I was able to disable the DHCP, in this new one, I am not sure if it’s possible.

Here is a screen shot of the DHCP settings on the router:

Then here is the DNS, but when I do a DNS leak test, it is not the assigned DNS, it goes to the ISP’s DNS.

This is not the DNS I assigned.

I am still new to this, I am wondering if it is possible that if I switch the DHCP to a static ip and I set the pi-hole, would that work?

If it is possible, I would like to know if I could install custom firmware to the router and maybe I get the pi-hole to block stuff again. Thanks



I don’t believe those are the local DHCP settings. The settings you are trying to change are meant for connecting to the internet, and you should leave it as DHCP (or your internet will not work). What does the “Local Network Settings” tab show? There should be another page somewhere to configure the local DHCP server.



These are your DHCP settings from your ISP (Internet Service Provider).

Unless they give you specific information about this particular setting, you should leave it as is.

The WAN (Wide area Network) IP is the one that your ISP assigns to you.

It’s the same with

That’s not a DNS, it’s your public facing IP.

The DNS is set-up here:

You can try to specify the IP of the Pi-hole (the internal one - if this is your IP of your Pi-hole).

Leave just that one and no secondary, unless you have a second device running another Pi-hole instance.

Here’s why:

Your DHCP settings (the ones you need) will be under your LAN (maybe that grayed out option on the bottom Local Network Settings)…

That’s where you (should) have a DNS option.

If you’re missing it, they your router doesn’t allow you to specify and broadcast LAN level settings.

You will get a lot more support on the Linksys forums as this place can only answer so much based on generic, logical settings for … well almost all routers…

Same thing with this one.

What you could do (try) is to disable the DHCP within your router, under the same settings (Local Network Settings) and ENABLE the DHCP server in the Pi-hole device …

That should take care of all the devices getting IPs… They’ll get all that + the DNS setting.

On top of it, you will see each device in the logs where as if you put the Pi-hole IP under those DNS settings in the router, you will see all requests originating from the router IP.



I have disabled the DHCP on my old router and the pi-hole did it’s job. On this new router, I cannot find a way to disable the DHCP so I could use the pi-hole.

After some searching on other forums, I found this entry which the message:
From the thread

Workaround to disable DHCP Server function in WRT32X 
‎04-08-2018 01:26 PM

I had the same issue to use WRT32X in bridge mode. Because of the better 5G WIFI support I want to keep the original firmware. Here is my workaround to disable DHCP server function:

1. Reduce the DHCP pool size includes only one IP: start IP, end IP (not changeable)

2. Make an IP fix assigment, assign the IP to a MAC adresse, which not exists in your home network.


Works without any issue. 

Does that post make any sense?



It does, but it’s one nasty way of handling the issue.

It basically reduces the range of dhcp available IPs.

You’d have to make sure the range on the Pi-hole DHCP does not include that IP
What you can do, is to set the IP of the Pi-hole device, either at the begining of that range or at the end, to occupy that one IP …


Pi-hole working with OpenVPN but not working without it

On the router it is only

On the pi, it is from
I turned on the DHCP on the pi

What you can do, is to set the IP of the Pi-hole device, either at the begining of that range or at the end, to occupy that one IP

I am not sure what that is



Set-up the IP of your Pi-hole device to either or and adjust the range accordingly (to include that 1 IP). This is on the router.

On the Pi-hole you can leave it as is or extend it if you need more IPs.


closed #16

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.