# Strange error and FTL not working on every reboot

**URL:** <https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391>\
**Category:** Community Help\
**Tags:** nginx\
**Created:** [April 18, 2021, 4:00pm UTC](https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391 "2021-04-18T16:00:30Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![miroslav\_vassilev](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/m/ecae2f/32.png) [@miroslav\_vassilev](https://discourse.pi-hole.net/u/miroslav_vassilev)\
**Post date:** [April 18, 2021, 4:00pm UTC](https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391/1 "2021-04-18T16:00:30Z")

</div>

**The issue I am facing:**

Since 2 days - on every reboot I am getting the following error:  
2021-04-18 17:39:00 DNSMASQ\_CONFIG FTL failed to start due to unknown interface eth0

**Details about my system:**  
Raspberry Pi 4 running ubuntu 20.04 with NGINX for serving multiple sub-domains

**What I have changed since installing Pi-hole:**  
I am just updating the standard ubuntu packages as well as the pihole. currently I am on:  
Pi-hole v5.3.1 Web Interface v5.5 FTL v5.8

The error is correctable after I run the following command:  
systemctl restart pihole-FTL.service

---

<div class="post-metadata">

**Author:** ![DanSchaper](https://discourse-cdn.pi-hole.net/user_avatar/discourse.pi-hole.net/danschaper/32/91_2.png) [@DanSchaper](https://discourse.pi-hole.net/u/DanSchaper)\
**Post date:** [April 18, 2021, 7:04pm UTC](https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391/2 "2021-04-18T19:04:10Z")

</div>

> [@miroslav\_vassilev](#):
>
> 2021-04-18 17:39:00 DNSMASQ\_CONFIG FTL failed to start due to unknown interface eth0

Either you don't have an `eth0` or it's not UP/UP when `pihole-FTL` is started.

Solutions are to either use the correct interface name, might be something like `enps0...` or delay the startup of `pihole-FTL` with [Configuration - Pi-hole documentation](https://docs.pi-hole.net/ftldns/configfile/#delay_startup)

---

<div class="post-metadata">

**Author:** ![miroslav\_vassilev](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/m/ecae2f/32.png) [@miroslav\_vassilev](https://discourse.pi-hole.net/u/miroslav_vassilev)\
**Post date:** [April 19, 2021, 7:36am UTC](https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391/3 "2021-04-19T07:36:28Z")

</div>

Thank you for the quick and explanatory answer! Indeed a delay in starting up the pihole-FTL will help - I already applied such workaround using crontab:

@reboot sleep 10 && systemctl restart pihole-FTL.service

Thank you for pointing out the logical way of doing it. The eth0 is correct - I do have such interface, but apparently it is starting a bit later due to some ubuntu updates - this is the only reason I can think of, as my configuration runs unchanged for almost a year now without any issues.  
Or there is a missing dependency for pihole-FTL.service 🙂

Thank you one more time !

---

<div class="post-metadata">

**Author:** ![miroslav\_vassilev](https://discourse-cdn.pi-hole.net/letter_avatar_proxy/v4/letter/m/ecae2f/32.png) [@miroslav\_vassilev](https://discourse.pi-hole.net/u/miroslav_vassilev)\
**Post date:** [April 19, 2021, 7:49am UTC](https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391/4 "2021-04-19T07:49:44Z")

</div>

DELAY\_STARTUP=5 was enough to cure it 🙂

---

<div class="post-metadata">

**Author:** ![system](https://discourse.pi-hole.net/uploads/default/original/3X/7/c/7c8792f649eeb921c5d2b4c41564ffa873d9a2b8.png) [@system](https://discourse.pi-hole.net/u/system)\
**Post date:** [May 10, 2021, 7:49am UTC](https://discourse.pi-hole.net/t/strange-error-and-ftl-not-working-on-every-reboot/46391/5 "2021-05-10T07:49:59Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
