Strange behaviour - DHCP not working


#1

I’ve added this source https://tspprs.com/dl/porn for blocklist… over 1mln lines. After few minutes ram usage jumped to 46% and DHCP stopped working. So I removed the list and everything got back to normality. What could it be?


#2

DHCP stopped working? Do you mean DNS?


#3

It’s about 1.76 million lines. A big list. A quick scan of the list doesn’t show any oddly formatted domains that would cause problems.

Depending how many domains you had previously in gravity, adding this block list could tax a Pi. What platform are you running your Pi-Hole on?


#4

No, DHCP… I think the pi was too busy and unable to answer to DHCP request… maybe there’s a limit to number of blocked domain… I don’t know


#5

Now that you have removed the large list, how many domains are being blocked?

What were the symptoms of DHCP not working?


#6

I’ve installed Raspbian, than PiHole and PiVPN.


#7

Original domains of PiHole… about 149k


#8

Are you still seeing this problem? What were the symptoms of not answering a DHCP request?


#9

No, after disabling that long list I had no more problems. However all LAN devices were unable to get an IP address. To resolve I had to put a static IP to my notebook and access pihole settings. Tailing pihole.log I saw DHCP request, offers and acks but the repeated 3-4 times and devices couldn’t actually get the assigned IP (all devices were with static DHCP leases)


#10

have you tried this list? What’s your RPi behaviour?


#11

If you update a debug log and post the token, we can take a look at your setup.


#12

I have to publish the token here?
I have to debug with the list enabled or disabled?


#13

Post the token (not the whole debug log) here. With or without the list loaded is OK. Whatever you have now.


#14

I added the list to a Pi Zero W that had the stock seven lists loaded. Domains blocked went from 130K to 1,893K. I didn’t notice a difference in performance on that Pi. Memory usage went up to 74%, but that’s about it. That particular Pi-Hole serves my mobile devices and they all seem to work fine.

I don’t use the Pi-Holes for DHCP - my router does all that.


#15

here it is
iljlzlbxe9


#16

You are running Pi-Hole with VPN? Are all your clients receiving IP addresses in the 192.168.1.x range?

From your debug log:

*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the tun0 interface:
   10.8.0.1/24 does not match the IP found in /etc/pihole/setupVars.conf (https://discourse.pi-hole.net/t/use-ipv6-ula-addresses-for-pi-hole/2127)

[i] Default IPv4 gateway: 192.168.1.1
   * Pinging 192.168.1.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

*** [ DIAGNOSING ]: Setup variables
    PIHOLE_INTERFACE=eth0
    PIHOLE_INTERFACE=tun0
    ....

#17

Yes, pihole with pivpn. all the clients receive the ip from pihole with no problems


#18

If this is the case, then the DHCP function is working properly. This is the process by which IP addresses are assigned.

Are you still having a problem with Pi-Hole resolving DNS requests?


#21

Now it works because I removed the list (disable the link I metion above) but if I enable it again DHCP stops working and assigning IP address.