Sometimes FTL went offline and lost connection to API

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

normal work of pi-hole.

Actual Behaviour:

every 1-2 days, often at night FTL went offline and lost connection to API. I can only restart the rp3 and after that pi-hole runs fine. I have tried to do pihole -r. A log cannot be uploaded during the event, but I have done a log after restarting.
Pi-hole connects to dnscrypt on port 5300 but dnscrypt seems to work even if FTL is offline. So I think it must be a problem of pi-hole.

Debug Token:

uuudgeu225

0 Likes

#2

Thats a known issue. Should be fixed in next update. The current dev release works just fine. Take a look: https://github.com/pi-hole/FTL/issues/496

0 Likes

#3

They are working on a fix.
If you want to help - please report your experience - you can install the current version of that fix with

pihole checkout ftl tweak/overhaul_overTime

0 Likes

#4

Thanks for reply. With the code base I am not familiar with. I have instaslled the fix. Is it possible to remove the fix if I occur problems? How?

0 Likes

#5

You get back to main version with

pihole checkout ftl master

0 Likes

#6

OK. Understood.
Unfortunately after switching to the fix it happened again. I have to stop and then to start the FTL service (sudo service pihole-FTL stop, sudo service pihole-FTL start). So it seems, that the fix does not solve my problem. I will see, if it will happen again.

0 Likes

#7

Please try the new release

1 Like

#8

Thanks for the reminder to update. I have first changed to master channel and second update pi-hole. I hope, the problem is gone now (finger crossed :smile: )

0 Likes

#9

Installing the 4.2.2 update solved the problem. Thanks a lot!

0 Likes

closed #10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

0 Likes