Some websites don't load, some load partially

Please follow the below template, it will help us to help you!

I am running latest pi hole installed today on a fresh image of latest Raspbian lite on a brand new RPiZeroW. Only some devices have connected so far (the ones that I manually reset the wifi). My phone tried connecting over and over again for about 20 minutes before it finally worked.

I tried some sites at random and a majority (~65%) appear to be working.

Sites that don't work at all or only partially work: reddit, github,, hacker news (,,, (lol)

Expected Behaviour:

Internet works, but without ads

Actual Behaviour:

Some sites work and ads are being blocked, other sites work but are slow or appear to work but stop loading half-way, other sites don't work at all. Browser apps like lastpass don't work, either.

Debug Token:


Have you seen this FAQ?

You also have some errors in your dnsmasq log:

   Mar 24 16:44:55 dnsmasq[13901]: failed to load names from /etc/pihole/local.list: No such file or directory
   Mar 24 16:44:55 dnsmasq[13901]: failed to load names from /etc/pihole/gravity.list: No such file or directory

What is the output of pihole -g

Ok, so since I'm running latest pihole I shouldn't have to worry about #1 on that faq. I don't have ULA so that means just run the 6 iptables commands listed in #2?

I'm not sure what the dnsmasq errors mean. I'm already way out of my league on this issue as it is.

Output for pihole -g:

  [i] Neutrino emissions detected...
  [✓] Pulling blocklist source list into range

  [i] Target: (hosts)
  [✓] Status: Retrieval successful

  [i] Target: (justdomains)
  [✓] Status: No changes detected

  [i] Target: (hosts)
  [✓] Status: No changes detected

  [i] Target: (blocklist.php?download=domainblocklist)
  [✓] Status: No changes detected

  [i] Target: (simple_tracking.txt)
  [✓] Status: No changes detected

  [i] Target: (simple_ad.txt)
  [✓] Status: No changes detected

  [i] Target: (ad_servers.txt)
  [✓] Status: No changes detected

  [✓] Consolidating blocklists
  [✓] Extracting domains from blocklists
  [i] Number of domains being pulled in by gravity: 145,343
  [✓] Removing duplicate domains
  [i] Number of unique domains trapped in the Event Horizon: 122,287

  [i] Number of blocklist source domains being added to the whitelist: 6
  [i] Number of whitelisted domains: 6
  [✓] Parsing domains into hosts format
  [✓] Cleaning up stray matter

  [✓] Force-reloading DNS service
  [✓] DNS service is running
  [✓] Pi-hole blocking is Enabled

What is the output of ls -lh /etc/pihole

total 19M
-rw-r--r-- 1 root   root     14 Mar 24 22:29 GitHubVersions
-rw-r--r-- 1 root   root    633 Mar 24 16:45 adlists.list
-rw-r--r-- 1 root   root    255 Mar 24 23:12 dhcp.leases
-rw-r--r-- 1 root   root    12M Mar 25 00:08 gravity.list
-rw-r--r-- 1 root   root   1.4K Mar 24 16:44 install.log
-rw------- 1 root   root   1.6M Mar 25 00:08
-rw------- 1 root   root   415K Mar 24 16:45
-rw------- 1 root   root   624K Mar 24 16:45
-rw------- 1 root   root   7.0K Mar 24 16:45
-rw------- 1 root   root    613 Mar 24 16:45
-rw------- 1 root   root    43K Mar 24 16:45
-rw------- 1 root   root   1.7M Mar 24 16:45
-rw-r--r-- 1 root   root   2.7M Mar 25 00:08 list.preEventHorizon
-rw-r--r-- 1 root   root    146 Mar 25 00:08 local.list
-rw-r--r-- 1 root   root     18 Mar 25 00:20 localbranches
-rw-r--r-- 1 root   root     36 Mar 25 00:20 localversions
-rw-r--r-- 1 root   root    234 Mar 24 16:44 logrotate
-rw-r--r-- 1 pihole pihole 224K Mar 25 00:26 pihole-FTL.db
-rw-r--r-- 1 root   root    461 Mar 24 22:57 setupVars.conf
-rw-r--r-- 1 root   root    117 Mar 24 16:45 whitelist.txt

Do you still see the issue? If so, make a new debug token.

Still persisting.

Debug token: i3xljen51x

It's saying some ipv6 addresses aren't matching something in some file. But I was under the assumption that these ipv6 issues were fixed in 3.1.

Those are unrelated, and the debug log says:

   ^ Please note that you may have more than one IP address listed.
   As long as one of them is green, and it matches what is in /etc/pihole/setupVars.conf, there is no need for concern.

I don't see anything wrong in your debug log. Did you run the IPTables commands from the FAQ?

I ran the commands and rebooted my laptop. That seemed to work. I'm able to access the sites I was having problems with previously!

What a relief! I am so happy, thank you so much.

Alas, I spoke too soon. I'm not getting blocked ads at all.

Make a new debug token.

How are you setting Pi-hole as your DNS server?

Thanks for the feedback. I've since purchased a new router and set up passthrough on the existing one. It's brought several benefits, but namely I've been able to set up the pihole as DNS and the issue above no longer exists. An expensive solution, but I'll likely keep and use the router for a very long time so it's more of an investment.

Tossed you guys a donation tonight. Thank you for the support and a great project. Keep up the good work.

I do have a follow-up question, if you don't mind....

Can I "hijack" the web server and put some projects up in another subdirectory, or will it get overwritten at some point? For instance, can I install another web app at http://pi.hole/projects without a worry of it disappearing?

1 Like

You can hijack the Web server, but it has caused issues for people in the past since the folder is a repo, but it's not a terribly high risk. We're moving away from this method in any case.

I don't plan on doing anything inside /admin. Just thinking about setting up other subdirectories so I can create some additional local webapps.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.