Some Sites very slow even with turned off IPv6

Please follow the below template, it will help us to help you!

Expected Behaviour:

Sites loading faster

Actual Behaviour:

Some Sites loading longer then 30s

Debug Token:


I have an FritzBox 7390 and PiHole on an Raspberry 3.
The Router (FB) is my DHCP, in PiHole is DHCP disabled. I set the PiHole IP into the Router under Network Setting - DNS Server AND under local DNS Server. On the PiHole I set the Router IP to the DNS Upstream.
I also tried to turn off IPv6 in the Router, but no success. The log is with IPv6, wich I like to keep enabled.

maby you have still open your port 443?
@jacob.salmela sorry ^^ ment that one XD

Can you verify this isn't the problem?

I checked those FAQ. As I understand the IPv6 issue is solved in v3.1 so here I have nothing to do.
The other both commands I run on the PiHole an rebootet.

I noticed no change in loading websites. Over the weekend I had some freinds here, there mobiles were logged into my WiFi but some phones noticed a bad WiFi and switched to mobile data. I have an good connection signal and a 50k provider. But loading the website takes longer then the screentime out :frowning:

currently i disabled IPv6. What else can I double check? I also have WireShark, but I dont know how to use.

Please help.

We also had a bug that we just fixed, bumping the version to 3.1.4, which contains a fix for a CIDR bug affecting IPv6 blocking.