SOLVED : updating gravity database stucks: system becomes unresponsive

Just updated Pihole but it get stuck when updating the gravity database.

System becomes (almost) totally unresponsive. My 1GB memory is full as is the swap file. Updating gravity database does not complete.

Use the 'hagezi' ultimate list (very large) but worked perfectly and updated fast up until now...
Seems new gravity db update procedure does some 'grep' on the raw file choking my system (NanoPi NEO2 with 1GB ram) completely.


Yes I agree I had the same problem after the update. I just plugged off and turned on my raspberry pi 3 b and make a backup via teleporter. Then I enter pihole -g -r recreate and imported the adlists/black/whitelists etc.

Then it working fine.

thank you.
mine would lock itself on another list, but it just need to be large enough for it to stall, as stated HERE.
i backuped up the pihole with the teleporter, "pihole -g -r recreate" and then restored the backup, then another "pihole -g", it took 1:30H but it completed.

Please, verify the new Hotfix v5.16.2 released.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.